UVA_10970_BigChocolate

28 篇文章 0 订阅
11 篇文章 0 订阅

10970 - Big Chocolate

Time limit: 3.000 seconds

Mohammad has recently visited Switzerland. As he
loves his friends very much, he decided to buy some
chocolate for them, but as this ne chocolate is very ex-
pensive (You know Mohammad is a little BIT stingy!),
he could only afford buying one chocolate, albeit a very
big one (part of it can be seen in gure 1) for all of them
as a souvenir. Now, he wants to give each of his friends
exactly one part of this chocolate and as he believes all
human beings are equal (!), he wants to split it into
equal parts.
The chocolate is an M N rectangle constructed
from M N unit-sized squares. You can assume that
Mohammad has also M N friends waiting to receive
their piece of chocolate.
To split the chocolate, Mohammad can cut it in vertical or horizontal direction (through the lines
that separate the squares). Then, he should do the same with each part separately until he reaches
M N unit size pieces of chocolate. Unfortunately, because he is a little lazy, he wants to use the
minimum number of cuts required to accomplish this task.
Your goal is to tell him the minimum number of cuts needed to split all of the chocolate squares
apart.
Input
The input consists of several test cases. In each line of input, there are two integers 1 M 300, the
number of rows in the chocolate and 1 N 300, the number of columns in the chocolate. The input
should be processed until end of le is encountered.
Output
For each line of input, your program should produce one line of output containing an integer indicating
the minimum number of cuts needed to split the entire chocolate into unit size pieces.
Sample Input
2 2
1 1
1 5
Sample Output
3
0
4


这个题目代码异常的简单,但是得到这么简短的代码却需要一些思考

首先是找规律,发现其实好像切法并不影响刀数

然后发现,每一刀必然会使巧克力的数目增加1,也只能增加1

因此最开始有1块,最后切成m*n块,需要也必须是m*n-1刀

#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        printf("%d\n",n*m-1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值