POJ_2406_PowerStrings

5 篇文章 0 订阅

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 40456 Accepted: 16833

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source


这个题目问一个串的最小重复串

重复了多少次

我用了一种比较蠢得方法,枚举了所有比一半短的字符串再跟自己匹配

但是其实这个问题用next数组的性质就可以解决了

具体的方法可以看HDU_1358的题解

#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
using namespace std;

const int MN=1e6+5;
const int MM=1e4+5;

char s1[MN],s2[MN];

int main()
{
    int n;
    int f;
    int ans;
    while(1)
    {
        scanf("%s",s1);
        if(s1[0]=='.')
            break;
        n=strlen(s1);
        for(int i=1;i<=n/2+1;i++)
        {
            if(n%i)
                continue;
            for(int j=0;j<i;j++)
                s2[j]=s1[j];
            f=1;
            for(int j=i;j<n;j++)
            {
                if(s2[j%i]!=s1[j])
                {
                    f=0;
                    break;
                }
            }
            if(f)
            {
                ans=n/i;
                printf("%d\n",ans);
                break;
            }
        }
        if(!f)
            printf("1\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值