POJ_2486_AppleTree(树状DP&&01背包)

Apple Tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9584 Accepted: 3192

Description

Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input

There are several test cases in the input
Each test case contains three parts.
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 ... N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200)
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i.
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent.
Input will be ended by the end of file.

Note: Wshxzt starts at Node 1.

Output

For each test case, output the maximal numbers of apples Wshxzt can eat at a line.

Sample Input

2 1 
0 11
1 2
3 2
0 1 2
1 2
1 3

Sample Output

11
2

Source

POJ Contest,Author:magicpig@ZSU


题意

给出一个树

最初人站在1点

每个点上有一些果子,一次到达就可以全部拿走

每次需要走一步到相邻的节点

问走k步最多可以得到多少果子


解题思路

树状背包dp,这个点是显然的

每次先对子节点做一遍01背包

dp[i][j]表示在i节点走j步可以得到的最大权值

这里注意的就是有时要走回头路

那么dp[i][j]要加一维,回到根节点或不回到跟节点

0不回来1回来的话

dp[rt][j][0]=max(dp[rt][j][0],dp[rt][j-k][1]+dp[t][k-1][0]);

不回来                               其他节点回来  当前节点不回来

dp[rt][j][0]=max(dp[rt][j][0],dp[rt][j-k][0]+dp[t][k-2][1]);

不回来                               其他节点不回来 当前节点回来

dp[rt][j][1]=max(dp[rt][j][1],dp[rt][j-k][1]+dp[t][k-2][1]);

回来                                   都要回来才行


#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

const int M=205;
int wi[M];
int dp[M][M][2];//0不回来,1回来
int n,m;
int ne;
struct Edge
{
    int to,nxt;
}edge[M*2];
int st[M];
void add_edge(int fr,int to)
{
    edge[ne].to=to;
    edge[ne].nxt=st[fr];
    st[fr]=ne++;
}
int isu[M];
void dfs(int rt)//树状背包
{
    isu[rt]=1;
    for(int i=0;i<=m;i++)
        dp[rt][i][0]=dp[rt][i][1]=wi[rt];
    //cout<<"dfs "<<rt<<endl;
    for(int i=st[rt];i!=-1;i=edge[i].nxt)
    {
        int t=edge[i].to;
        if(isu[t])
            continue;
        dfs(t);
        for(int j=m;j>=1;j--)
        {
            for(int k=1;k<=j;k++)
            {
                dp[rt][j][0]=max(dp[rt][j][0],dp[rt][j-k][1]+dp[t][k-1][0]);
                dp[rt][j][0]=max(dp[rt][j][0],dp[rt][j-k][0]+dp[t][k-2][1]);
                dp[rt][j][1]=max(dp[rt][j][1],dp[rt][j-k][1]+dp[t][k-2][1]);
            }
        }
    }
}

int main()
{
    int a,b;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        ne=0;
        memset(st,-1,sizeof(st));
        memset(isu,0,sizeof(isu));
        //m++;
        for(int i=1;i<=n;i++)
            scanf("%d",&wi[i]);
        for(int i=1;i<=n-1;i++)
        {
            scanf("%d%d",&a,&b);
            add_edge(a,b);
            add_edge(b,a);
        }
        dfs(1);
        printf("%d\n",max(dp[1][m][0],dp[1][m][1]));
    }
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值