hdu 5477(2015 ACM/ICPC Asia Regional Shanghai Online)

啦啦啦,经常爆零的帕斯喵又来切题了。

 

Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)

 


 

Input
In the first line there is an integer t ( 1t50 ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers: Li,Ri , which represents the interval [Li,Ri] is swamp.
1n100,1L105,1A10,1B101Li<RiL .
Make sure intervals are not overlapped which means Ri<Li+1 for each i ( 1i<n ).
Others are all flats except the swamps.
 


 

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
 


 

Sample Input
  
  
1 2 2 2 5 1 2 3 4
 


 

Sample Output
  
  
Case #1: 0
 

题意:一个小伙,骑车经过一条公路,这条公路上有沼泽和平地,经过沼泽就会消耗一些体力,经过平地就会恢复一些体力(这条公路也是66666偷笑偷笑),然后呢,问这小伙

在最开始,需要至少准备多少体力才能穿过这条公路呢?
首先需要注意的是,题目中给出的区间(沼泽)是没有重叠的哦。蠢萌的帕斯喵最开始没有注意。 

思路:用一个数组记录小伙每次穿过沼泽后的体力,然后找到最小值,如果最小值非负,代表最开始不需要准备体力,如果为负,取反即可。

总的来看,这题一不卡时间,二不卡数据,是一道签到题哦。

代码

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int l[110],r[110];
int ans[110];//用来记录每次经过沼泽之后的体力值
int main()
{
    int t,n,a,b,flag=0,L;//L最好大写哦
    cin>>t;
    while(t--)
    {
     flag++;
     memset(ans,0,sizeof(ans));
     cin>>n>>a>>b>>L;
     for(int i=0;i<=n-1;i++)
        cin>>l[i]>>r[i];
     ans[0]=l[0]*b-(r[0]-l[0])*a;//第一次经过沼泽后的体力值
     for(int i=1;i<=n-1;i++)
     {
      ans[i]=ans[i-1]+(l[i]-r[i-1])*b-(r[i]-l[i])*a;
     }
     sort(ans,ans+n);//啦啦啦,sort大法好
     if(ans[0]>=0)
       printf("Case #%d: %d\n",flag,0);
     else
       printf("Case #%d: %d\n",flag,ans[0]*(-1));
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值