POJ 2752 Seek the Name, Seek the Fame (kmp)

Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20454 Accepted: 10646

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

给定一个字符串,求出所有既是前缀又是后缀的子串。


思路

KMP 的next数组的运用(改进前),如果next数组中next[ i ]= k 正值,那么就代表这从 “0 ~ i-1”位置的子串的前缀后缀相同的最大长度为k,并且k代表着与当前后缀最大匹配的前缀位置。


 0123456789101112
字符串aabaabaabaab 
next [ ]-1010123456789


如表 next[ 12 ] =  9 , 9 所在位置的前缀 为 a a b a a b a a b,与后缀是最大匹配 , next[  9 ] =  6 ,6 所在位置的前缀 为 a a b a a b,仍然和后缀匹配,第二大匹配

next[ ] = 3 , ,a a b, next[ 3 ] = 0,表明需要回溯到头再进行匹配。

因而通过前后缀重复次数的计数,以及next数组的调转,我们就能尽可能少的重复 重复位置的匹配。每次都能跳转到 前后缀最大公共的位置。


因而对于这个题,我们从最后的next[ len ]开始,不断地找 next[next[i]], 所找的前缀都和最后的后缀所匹配,所在位置的值就是前后缀相同的长度。全部累加就可以了。

另外还要加上满足条件的字符串本身。

分析:转载于 http://blog.csdn.net/chaiwenjun000/article/details/49274945



此图也可以很明白的看出,不断递归找到Next[Next[len-1]]

#include<iostream>
#include<cstring>
#include<algorithm>
#include<stdio.h>
#include<vector>
using namespace std;
const int maxn =1e6+100;
char a[maxn];
int f[maxn],n;

void kmp_pre(char x[],int m,int next[])
{
    int i,j;
    j=next[0]=-1;
    i=0;
    while(i<m){
        while(-1!=j&&x[i]!=x[j])j=next[j];
        next[++i]=++j;
    }
}

int main()
{
    int cnt=0;
   while(scanf("%s",a)!=EOF)
   {
       vector<int>q;
       memset(f,0,sizeof(f));
       n=strlen(a);
       kmp_pre(a,n,f);
       int temp;
       for(int i=n;i>0;)  q.push_back(i), i=f[i];
       printf("%d",q[q.size()-1]);
       for(int i=q.size()-2;i>=0;i--) printf(" %d",q[i]);
       printf("\n");
   }
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值