Mr long的博客

学习分享,记录学习

关于IDEA使用遇到的坑

1.关于IDEA使用不同jdk版本进行编译
报错描述:
IntelliJ Idea编译报错:javacTask: 源发行版 1.8 需要目标发行版 1.8

出错原因以及解决办法:
公司项目使用的jdk版本是1.7,但是最近学习java 8的流编程所以需要更改jdk的版本,我直接根据提示点击了更改更改language level引入了java 8的lambda表达式
直接去修改项目中jdk支持的版本
更改使用的jdk.png!thumbnail但是项目本身也是需要进行更改jdk的版本的否则它在编译的时候还是找不到对应的jdk版本,这里我们需要设置对应项目的jdk版本进行更改
设置实际项目中运行的jdk版本和整个项目的jdk版本

总结:
设置项目jdk版本.png!thumbnail这时候再运行就好了
一般来说,高版本都是对低版本做了兼容处理的,我们在使用的时候直接根据需求设置最高满足项目运行的jdk版本然后在每一个项目下使用不同的jdk版本也可以完美的进行支持。

2.关于IDEA缓存造成的报错
本人因为有事然后回学校参加答辩花了两周时间,当回到公司重新down项目熟悉代码遇到的问题
问题描述:
IntellJ Idea遇到Errors occurred while compiling module + 项目名的
明明就是存在那个类但是IDEA一直报错找不到相应的类

思路:
我以为是因为刚激活的话里面的内容被还原了,但是我仔细检查了之后仍然没发现任何端倪,,本着不怕死的精神,我搞了半天,从版本号到依赖到jdk版本都一一对比过了毕竟回来时候刚把IDEA激活了,结果仍然一无所获,后面百度了半天终于自己找到原因可能是IDEA缓存的问题,于是动手

解决问题方法和步骤:
IDEA清除缓存
总结:
之后重新down项目再次导入程序完美运行!~!!我猜想可能原因是以前对IDEA的设置导致现在再次运行时候仍然找不到正确的类,但是这些类确实是存在的。

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/baidu_34168157/article/details/80321302
个人分类: IDEA那些坑
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

关于IDEA使用遇到的坑

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭