;练习二1002


Strange fuction
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 81   Accepted Submission(s) : 38
Problem Description
Now, here is a fuction:<br>&nbsp;&nbsp;F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 &lt;= x &lt;=100)<br>Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2<br>100<br>200
 

Sample Output
  
  
-74.4291<br>-178.8534
 

Author
Redow
 

思路:

由于;F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x是一个先减后增的函数,用三分搜索。

代码:

 

#include<iostream>
#include<cmath>
#include<iomanip>
using namespace std;
double zhi(double x,double y)
{
return (6*pow(x,7)+8*pow(x,6)+
7*pow(x,3)+5*pow(x,2)-y*x);
}
int main()
{
int t;
cin>>t;
for(int i=0;i<t;i++)
{
double y,x,low=0,heigh=100,
mid,mmid;
cin>>y;
while(heigh-low>0.000001)
{
mid=(low+heigh)/2;
mmid=(mid+heigh)/2;
if(zhi(mid,y)<zhi(mmid,y))
heigh=mmid;
else low=mid;
}
double min=zhi(mid,y);
if(zhi(mmid,y)<zhi(mid,y))
min=zhi(mmid,y);
cout<<setiosflags(ios::fixed)<<
setprecision(4)<<min<<endl;
}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值