练习三1003

Problem C
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 46   Accepted Submission(s) : 11
Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.<br><br><center><img src=/data/images/1087-1.jpg></center><br><br>The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.<br>Your task is to output the maximum value according to the given chessmen list.<br>
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:<br>N value_1 value_2 …value_N <br>It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.<br>A test case starting with 0 terminates the input and this test case is not to be processed.<br>
 

Output
For each case, print the maximum according to rules, and one line one case.<br>
 

Sample Input
  
  
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
  
  
4 10 3
 

Statistic | Submit | Back

题意:

一条路上,从开始点到终点,只能从数小的点跳到数大的点,只能向前跳,开始的数无穷小,终点的数无穷大,求经过的数字之和最大是多少。

思路:

本质是一个关于递增字数列的问题,从第二个开始依次计算他前面的最大递增子数列再加上他自身,最后一个循环找出最大的即可。

代码:

#include<iostream>
using namespace std;
int main()
{
    int n;
    while(cin>>n&&n)
    {
        int a[1001],b[1001];
        for(int i=1;i<=n;i++)
        cin>>a[i];
        b[1]=a[1];
        for(int i=2;i<=n;i++)
        {
            int cnt=0;
            for(int j=1;j<=i;j++)
            {
                if(a[i]>a[j]){
                if(b[j]>cnt)
                cnt=b[j];
                }
            }
            b[i]=cnt+a[i];
        }
        int sum=b[1];
        for(int i=2;i<=n;i++)
        if(b[i]>sum)
        sum=b[i];
        cout<<sum<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值