poj 1797

Heavy Transportation
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 33180 Accepted: 8803

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:

4

题解:求从原点到终点的最大承重量,单源路径问题,可以根据迪杰斯特拉算法,这时首先要找dis数组中最大的,以它为起点,更新

dis数组,要比较max和map[flag][j]最小的,然后再取和dis[j]中最大的,即在同一条路中选择最小的,不同路中选择最大的。

#include<stdio.h>
#define INF 1<<30
int dis[1001], weight[1001][1001], visited[1001] = {0};
void get_weight(int weight[][1001], int n) {
	int i, j, max, flag;
	for(i = 1; i <= n; i++)
		dis[i] = weight[1][i];
	visited[1] = 1;
	for(i = 1; i < n; i++) {
		max = -INF;
		for(j = 1; j <= n; j++)
			if(dis[j] > max && !visited[j]) {
				max = dis[j];
				flag = j;
			}
		visited[flag] = 1;
		for(j = 1; j <= n; j++) {
			if(dis[j] < (max > weight[flag][j] ? weight[flag][j] : max) && !visited[j])
				dis[j] = max > weight[flag][j] ? weight[flag][j] : max;
		}
	}
}
int main() {
	int t, n, m,count = 1;
	scanf("%d", &t);
	while(t--) {
		int i, j, street1, street2, wei;
		for(i = 0; i < 1001; i++) {
			visited[i] = 0;
			for(j = 0; j < 1001; j++)
				weight[i][j] = -1;
		}
		scanf("%d%d", &n, &m);
		for(i = 1; i <= m; i++) {
			scanf("%d%d%d", &street1, &street2, &wei);
			if(wei > weight[street1][street2]) {
				weight[street1][street2] = wei;
				weight[street2][street1] = wei;
			}	
		}
		get_weight(weight, n);
		printf("Scenario #%d:\n", count);
		count++;
		printf("%d\n", dis[n]);
		printf("\n");
	}
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值