Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 10890 | Accepted: 6065 |
Description
N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.
The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.
Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B
Output
* Line 1: A single integer representing the number of cows whose ranks can be determined
Sample Input
5 5 4 3 4 2 3 2 1 2 2 5
Sample Output
2
题解:如果1可以打败2,2可以打败3,那么1可以打败3,所以只要确定某一个数与其他n-1个之间的关系,可能是打败,也可能是被打败,就能确定他的名字。
#include<stdio.h>
int map[105][105];
void floya(int n) {
int i, j, k;
for(k = 1; k <= n; k++)
for(i = 1; i <= n; i++)
for(j = 1; j <= n; j++)
if(map[i][k] && map[k][j])
map[i][j] = 1;
}
int main() {
int n, m;
while (scanf("%d%d", &n, &m) != EOF) {
int i, j;
for(i = 1; i < 105; i++)
for(j = 1; j < 105; j++)
map[i][j] = 0;
int count, win, down, sum = 0;
for(i = 1; i <= m; i++) {
scanf("%d%d", &win, &down);
map[win][down] = 1;
}
floya(n);
for(i = 1; i <= n; i++) {
count = 0;
for(j = 1; j <= n; j++)
if(map[i][j] || map[j][i])
count++;
if(count == n - 1)
sum++;
}
printf("%d\n", sum);
}
}