poj 1724

ROADS
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14615 Accepted: 5298

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find  the shortest path from the city 1 to the city N  that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

题解:从1出发到n地点,在有限的钱数内,找到最短的路径,可以采用链式前向星存储加上优先队列(bfs),还可以采用dfs当距离变大就回溯,遍历所有点找到最小的路径。

代码1:

#include<stdio.h>
#include<string.h>
#include<queue>
#define Max 10005
#define INF 0x3f3f3f
using namespace std;
typedef struct nod {
	int to;
	int next;
	int length;
	int money;
}nod;
struct s{
	int num;
	int length;
	int money;
};

bool operator < (s node1, s node2) {
		return node1.length > node2.length;
}

nod edge[Max];
priority_queue<s>que;
int head[105];
int count, k, n, r; 

void add(int s, int d, int l, int t) {
	edge[count].to = d;
	edge[count].length = l;
	edge[count].money = t;
	edge[count].next = head[s];
	head[s] = count++;
}

void spfa() {
	s temp, nn;
	int u;
	int act = -1;
	while(!que.empty())
		que.pop();
	temp.length = 0;
	temp.num = 1;
	temp.money = 0;
	que.push(temp);
	while(!que.empty()) {
		temp = que.top();
		que.pop();
		if(temp.num == n) {
			act = temp.length;
			break;
		}
		for(u = head[temp.num]; u != -1; u = edge[u].next) {
			if(temp.money + edge[u].money <= k) {
				nn.money = temp.money + edge[u].money;
				nn.length = temp.length + edge[u].length;
				nn.num = edge[u].to;
				que.push(nn);
			}		
		}
	}
	printf("%d\n", act);
}

int main(){
	int s, d, l, t, i;
	while(scanf("%d%d%d", &k, &n, &r) != EOF) {
		count = 1;
		memset(head, -1, sizeof(head));
		for(i = 1; i <= r; i++) {
			scanf("%d%d%d%d", &s, &d, &l, &t);
			add(s, d, l, t);
		}
		spfa();
	}
}
 

代码2:

#include<stdio.h>
#include<string.h>
#include<queue>
#define Max 10005
#define INF 0x3f3f3f
using namespace std;
typedef struct nod {
	int to;
	int next;
	int length;
	int money;
}nod;
struct s{
	int num;
	int length;
	int money;
};
int visited[105];
nod edge[Max];
int head[105];
int count, k, n, r, ans; 

void add(int s, int d, int l, int t) {
	edge[count].to = d;
	edge[count].length = l;
	edge[count].money = t;
	edge[count].next = head[s];
	head[s] = count++;
}

void dfs(int num, int dis, int money) {
	int i;
	if(dis > ans)
		return;
	if(num == n && money >= 0 && dis < ans)
		ans = dis;
	for(i = head[num]; i != -1; i = edge[i].next) {
		if(!visited[edge[i].to] && money >= edge[i].money) {
			visited[edge[i].to] = 1;
			dfs(edge[i].to, dis + edge[i].length, money - edge[i].money);
			visited[edge[i].to] = 0;
		}
	}	
}

int main(){
	int s, d, l, t, i;
	while(scanf("%d%d%d", &k, &n, &r) != EOF) {
		count = 1;
		memset(visited, 0, sizeof(visited));
		memset(head, -1, sizeof(head));
		for(i = 1; i <= r; i++) {
			scanf("%d%d%d%d", &s, &d, &l, &t);
			add(s, d, l, t);
		}
		ans = INF;
		dfs(1, 0, k);
		if(ans != INF)
			printf("%d\n", ans);
		else
			printf("-1\n");
	}
}
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值