ACdream 1196 KIDx's Pagination


One Day, KIDx developed a beautiful pagination for ACdream. Now, KIDx wants you to make another one.

The are n pages in total.
The current page is cur.
The max distance to current page you can display is d.

Here are some rules:

  • The cur page button is disabled.
  • If cur page is the first page, the button "<<" should be disabled.
  • If cur page is the last page, the button ">>" should be disabled.
  • If the button "x" is disabled, print "[x]"; else print "(x)".
  • You should not display the "..." button when there is no hidden page.

You can assume that the button "..." is always disabled.

Input
There are multiple cases.
Ease case contains three integers n, cur, d.
1 ≤ n ≤ 100.
1 ≤ cur ≤ n.
0 ≤ d ≤ n.
Output
For each test case, output one line containing "Case #x: " followed by the result of pagination.
Sample Input
10 5 2
10 1 2
Sample Output
Case #1: (<<)[...](3)(4)[5](6)(7)[...](>>)
Case #2: [<<][1](2)(3)[...](>>)
Hint

Case 1: 

Case 2: 

原题链接:KIDx's Pagination
认真看题的话,这题不难,挺循规蹈矩的!

来看代码:

#include <iostream>
#include <cstdio>
 
using namespace std;
 
int main()
{
    int n,cur,d,tp,cnt = 0;
    int i;
    while(scanf("%d %d %d",&n,&cur,&d)!=EOF)
    {
        printf("Case #%d: ",++cnt);
        if(cur != 1) 
			printf("(<<)");
        else 
			printf("[<<]");
        if(cur - d > 1) 
			printf("[...]");
        if(cur - d < 1) 
			tp = 1;
        else 
			tp = cur - d;
        for(i = tp; i < cur && i >= 1; i++)
            printf("(%d)",i);
        printf("[%d]",cur);       //以cur为分水岭
        for(i = cur + 1; i <= cur + d && i <= n; i++)
            printf("(%d)",i);
        if(cur + d < n) 
			printf("[...]");
        if(cur != n) 
			printf("(>>)");
        else 
			printf("[>>]");
        puts("");  //这条语句等价于printf("\n");或者cout>>endl;
    }
    return 0;
}
题不难,代码也不难理解,只要认真耐心看完就能懂哦!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值