zoj1610

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.



Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1



线段树的区间更新

要注意init的时候范围不是1~n而是1~8000

sum[maxn]表示该区间内的颜色,如果没有颜色或者有多个颜色则赋值为-1

code:

#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
const int N = 10005;
#define lson l,m,rt<<1
#define rson m,r,rt<<1|1

int sum[N<<2],add[N<<2];
int c[N];
struct Node
{
    int l,r;
    int mid()
    {
        return (l+r)>>1;
    }
} tree[N<<2];

void PushDown(int rt)
{
    sum[rt<<1]=sum[rt<<1|1]=sum[rt];
    sum[rt]=-1;
}

void build(int l,int r,int rt)
{
    tree[rt].l = l;
    tree[rt].r = r;
    add[rt] = 0;
    sum[rt]=-1;
    if(l == r-1)return ;
    int m = tree[rt].mid();
    build(lson);
    build(rson);
}

void update(int c,int l,int r,int rt)
{
    //printf("l=%d r=%d rt=%d\n",l,r,rt);
    if(tree[rt].l == l && r == tree[rt].r)
    {
        sum[rt] = c;
        return;
    }
    if(sum[rt]!=-1)PushDown(rt);
    int m = tree[rt].mid();
    if(r <= m) update(c,l,r,rt<<1);
    else if(l >=m) update(c,l,r,rt<<1|1);
    else
    {
        update(c,l,m,rt<<1);
        update(c,m,r,rt<<1|1);
    }
}

int temp;
void Count(int rt)
{
    if(sum[rt]!=-1)
    {
        if(sum[rt]!=temp)
        {
            temp=sum[rt];
            c[temp]++;
        }
        return ;
    }
    if(tree[rt].l==tree[rt].r-1)
    {
        temp=-1;
        return ;
    }
    Count(rt<<1);
    Count(rt<<1|1);
}

//void output(int k,int l,int r)
//{
//    printf("l=%d r=%d sum=%d\n",l,r,sum[k]);
//    if(l==r-1)return ;
//    output(k<<1,l,(l+r)/2);
//    output(k<<1|1,(l+r)/2,r);
//}

int main()
{
    int n;
    while(scanf("%d",&n)!=-1)
    {
        build(1,8001,1);
        memset(c,0,sizeof(c));
        while(n--)
        {
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            update(z,x+1,y+1,1);
        }
        temp=-1;
        Count(1);
        for(int i=0;i<=8000;i++)
        {
            if(c[i])
            {
                printf("%d %d\n",i,c[i]);
            }
        }
        puts("");
    }
    return 0;
}

本人蒟蒻,如有错误,还望指正


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值