hihocoder 1425 What a beautiful Lake!

What a beautiful Lake!

Description

Weiming Lake, also named "Un-named Lake", is the most famous scenic spot in Peking University. It is located in the north of the campus and is surrounded by walking paths, small gardens, and old red buildings with typical Chinese curly roofs. The lake was once the royal garden in Qing Dynasty. Boya tower stands on a little hill beside the lake. The lake and the tower form a distinctive landscape and a symbol of Peking University.

Weiming Lake is a very good place for studying, reading, skating in the winter, and of course, jogging. More and more students and teachers run or walk around Weiming Lake every day and show how many paces they have covered in the mobile app WeChat Sports to get "Zans" (applauses).

ACMer X also enjoys jogging around Weiming Lake. His watch can measure and record an altitude value every meter. After a round of running, X collected the altitude data around the lake. Now he wants to find out the longest slope around the lake. 

Input

There are no more than 20 test cases.

Each case has two lines.

The first line is an integer N (2 <= N <= 100) meaning that the length of the road around the lake is N meters.

The second line contains N integers a1,a2...aN, (0<= a1,a2...aN <= 100) indicating N altitude sample values around the lake. The samples are given in clockwise order, and the distance between two adjacent samples is one meter. Of course the distance between a1 and aN is also one meter.

The input ends by a line of 0.

Output

For each test case, print the length of the longest slope in meters. A slope is a part of the road around the lake, and it must keep going up or going down. If there are no slope, print 0.

Sample Input

 
  

4

1 1 1 1

8

5 1 2 3 4 5 6 2

6

5 4 3 2 1 2

10

1 0 2 3 2 2 3 4 3 2

0

Sample Output

 
  

0

5

4

4


猜题意:

找最长连续单调子序列的长度;

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int maxn=210;

int a[maxn];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        int k1=1,k2=1;
        int ans1=0,ans2=0;
        memset(a,0,sizeof(a));
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(int i=n; i<2*n; i++)
            a[i]=a[i-n];
//        for(int i=0; i<2*n; i++)
//            printf("%d ",a[i]);
//        printf("\n");
        for(int j=0; j<2*n-1; j++)
        {
            if(a[j]<a[j+1])
                k1++;
            else
                k1=1;
            ans1=max(ans1,k1);
            if(a[j]>a[j+1])
                k2++;
            else
                k2=1;
            ans2=max(ans2,k2);
        }
        printf("%d\n",max(ans1,ans2)-1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值