nyoj 1278 【二叉搜索树】 G: Prototypes analyze

问题 G: Prototypes analyze

时间限制: 1 Sec  内存限制: 64 MB
提交: 12  解决: 7
[ 提交][ 状态][ 讨论版]

题目描述

ALpha Ceiling Manufacturers (ACM) is analyzing the properties of its new series of Incredibly Collapse-Proof Ceilings (ICPCs).  An ICPC consists of n layers of material, each with a different value of collapse resistance (measured as a positive integer). The analysis ACM wants to run will take the collapse-resistance values of the layers, store them in a binary search tree, and check whether the shape of this tree in any way correlates with the quality of the whole construction. Because, well, why should it not?  To be precise, ACM takes the collapse-resistance values for the layers, ordered from the top layer to the bottom layer,  and inserts them one-by-one into a tree. The rules for inserting a value v are:

• If the tree is empty, make v the root of the tree.

 If the tree is not empty, compare v with the root of the tree.

 If v is smaller, insert v into the left subtree of the root,

 otherwise insert v into the right subtree.

 

ACM has a set of ceiling prototypes it wants to analyze by trying to collapse them. It wants to take each group of ceiling prototypes that have trees of the same shape and analyze them together. For example , assume ACM is considering five ceiling prototypes with three layers each, as described by Sample Input 1 and shown in Figure C.1. Notice that the first prototype’s top layer has collapseresistance value 2, the middle layer has value 7, and the bottom layer has value 1. The second prototype has layers with collapse-resistance values of 3, 1, and 4 – and yet these two prototypes induce the same tree shape, so ACM will analyze them together. Given a set of prototypes, your task is to determine how many different tree shapes they induce.

 

输入

The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8). Each test case specifies : ● Line 1: two integers n (1 ≤ n ≤ 50), which is the number of ceiling prototypes to analyze, and k (1 ≤ k ≤ 20), which is the number of layers in each of the prototypes. ● The next n lines describe the ceiling prototypes. Each of these lines contains k distinct integers ( between 1 and 1e6, inclusive ) , which are the collapse-resistance values of the layers in a ceiling prototype, ordered from top to bottom.

输出

For each test case generate a single line containing a single integer that is the number of different tree shapes.

样例输入

15 32 7 11 5 93 1 42 6 59 7 3

样例输出

4

提示

[ 提交][ 状态]

思路:最重要的是会建树;如果不会建立二叉树,学习: http://blog.csdn.net/stpeace/article/details/9067029
            对于给出的二叉树建树,然后判断有多少种形状;
            还有的其他思路是,对于建好的树进行中序,先序遍历得到的顺序存到map[string][string],最后输出map.size();
代码:
//BST二叉搜索树;
#include<cstdio>
#include<iostream>
using namespace std;

int flag;

typedef struct Node
{
    int key;
    struct Node *lChild,*rChild;
} Node,*BST;

bool BSTInsert(Node * &p,int element)
{
    if(p==NULL)
    {
        p=new Node;
        p->key=element;
        p->lChild=p->rChild=NULL;
        return true;
    }
    if(element==p->key)
        return false;
    if(element<p->key)
        return BSTInsert(p->lChild,element);
    return BSTInsert(p->rChild,element);
}

void judge(BST T1,BST T2)  //判断形状;
{
    if(T1==NULL&&T2==NULL)
        return;
    else if(T1&&T2)
    {
        judge(T1->lChild,T2->lChild);
        judge(T1->rChild,T2->rChild);
    }
    else
        flag=0;
}

int main()
{
    int t,n,k,x;
    BST tree[55];

    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for(int i=0; i<n; i++)  
        {
            BST T=NULL; 
            for(int j=0; j<k; j++)  //建树;
            {
                scanf("%d",&x);
                BSTInsert(T,x);
            }
            tree[i]=T;
        }

        //找形状种类数;
        int ans=0;
        for(int i=0; i<n; i++)
        {
            int flog=1;
            for(int j=i+1; j<n; j++)
            {
                flag=1;
                judge(tree[i],tree[j]);
                if(flag)
                {
                    flog=0;
                    break;
                }
            }
            if(flog)
                ++ans;
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值