PAT Advanced 1138 Postorder Traversal (25)

问题描述:

1138 Postorder Traversal (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

又一天的摸鱼时光。。。。

庄子与惠子游于濠梁之上。庄子曰:“鯈鱼出游从容,是鱼之乐也。”惠子曰:“子非鱼,安知鱼之乐?”庄子曰:“子非我,安知我不知鱼之乐?”惠子曰:“我非子,固不知子矣;子固非鱼也,子之不知鱼之乐全矣!”庄子曰:“请循其本。子曰‘汝安知鱼乐’云者,既已知吾知之而问我,我知之濠上也。” (《庄子与惠子游于濠梁之上》)

AC代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
//	freopen("data.txt","r",stdin);
	int n,m,k;
	scanf("%d",&n);
	vector<int> v1;
	vector<int> v2;
	map<int,int> ma;
	map<int,int>::iterator itm;
	vector<int>::iterator itv1,itv2,v1b,v1e,v2b,v2e;
	for(int i=0;i<n;i++)
	{
		scanf("%d",&m);
		v1.push_back(m);
	}
	for(int i=0;i<n;i++)
	{
		scanf("%d",&m);
		if(m==v1[0])
		k=i;
		v2.push_back(m);
		ma[m]=i;
	}
	v1b=v1.begin();
	v2b=v2.begin();
	v1e=v1.end();
	v2e=v2.end();
	itv2=v2b+k;
	for(;;)
	{
		itv1=v2e;
		v2e=itv2;
		++itv2;
		if(v2e-v2b>1)
		{
			++v1b;
			v1e=v1b+(v2e-v2b);
		}
		else if(v2e-v2b==1)
		{
			printf("%d",*v2b);
			break;
		}
		else
		{
			v2b=itv2;
			v2e=itv1;
			if(v2e-v2b>1)
			{
				v1b=v1b+(itv2-v2b)+1;
			}
			else if(v2e-v2b==1)
			{
				printf("%d",*v2b);
				break;		
			}
			else
			{
				printf("%d",*v1b);
				break;				
			}
		}
		itv2=find(v2b,v2e,*v1b);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值