1008 Elevator (20 分)

1008 Elevator (20 分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

清明节ac的,这道题很简单,一遍过。意思就是开始电梯在第零层,每上升一层需要6秒,然后停留5秒,下降一层需要4秒。

给出一个列表,表示电梯的运行轨迹。问一共需要几秒?

先给出一个正整数N,随后是N给数,表示楼层;

具体代码:

#include <iostream>
#include <vector>
#include <queue>
#include <math.h>
using namespace std;
int main()
{
    queue <int> q;
    int n;
    int floor;
    int f=0;
    int time,total=0;
    cin>>n;
    for(int i=0; i<n; i++)
    {
        cin>>floor;
        q.push(floor);
    }
    int len=q.size();
    while(!q.empty())
    {
        floor=q.front();
        q.pop();
        time=f-floor;
        f=floor;
        if(time<0)
        {
            total=total+abs(time)*6;
        }

        else if(time>0)
        {
             total=total+time*4;
        }

    }
    total=total+len*5;
    cout<<total<<endl;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值