1011 World Cup Betting (20 分)

1011 World Cup Betting (20 分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

题的意思就是选出美行中最大的一个数;

然后按照他给出的公式相乘;

第一列代表W,依次T,L;

#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
#include <iomanip>
using namespace std;

int main()
{
    vector <double> q;
    map <double,int> m1,m2,m3;
    double bet;
    int i,j;
    double max_p;
    int mbet4[4]= {0};
    map <double,int>::iterator it,mbet;
    for( i=0; i<3; i++)
    {
        max_p=-1;
        for( j=0; j<3; j++)
        {
            cin>>bet;
            if(i==0&&bet>max_p)
            {
                max_p=bet;
                m1[max_p]=j;
            }
            else if(i==1&&bet>max_p)
            {
                max_p=bet;
                m2[max_p]=j;
            }
            else
            {
                max_p=bet;
                m3[max_p]=j;
            }

        }
    }
    mbet=m1.begin();
    for(it=m1.begin(); it!=m1.end(); it++)
    {
        if(it->first>mbet->first)
            mbet=it;
    }
    max_p=1;
    mbet4[0] = mbet->second;
    max_p=max_p*mbet->first;
    mbet=m2.begin();
    for(it=m2.begin(); it!=m2.end(); it++)
    {
        if(it->first>mbet->first)
            mbet=it;
    }
    mbet4[1]=mbet->second;
    max_p=max_p*mbet->first;
    mbet=m2.begin();
    for(it=m3.begin(); it!=m3.end(); it++)
    {
        if(it->first>mbet->first)
            mbet=it;
    }
    mbet4[2]=mbet->second;
    max_p=max_p*mbet->first;
    for( i=0; i<3; i++)
    {
        if(mbet4[i]==0)
            cout<<'W'<<' ';
        if(mbet4[i]==1)
            cout<<'T'<<' ';
        if(mbet4[i]==2)
            cout<<'L'<<' ';
    }
    cout<<fixed<<setprecision(2)<<(max_p*0.65-1)*2;

}


这道题写的有点麻烦了,因为想练一下map的用法,就用了map;

本来想着把三个map里的最大值再合并一个map里;

但有可能map的second是一样的,就会覆盖;?(开始用三个map时就是想到了这一点,然后莫名其妙)

还是用了数组

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园建设是在国家政策推动下,为深化教育改革、提升教育质量和管理效率而提出的重要项目。该项目旨在通过信息化手段,解决传统教育中存在的资源分散、管理混乱等问题,实现教育资源的高效利用和教学质量的全面提升。 目前,教育信息化虽取得一定进展,但面临“孤岛架构”的挑战,包括硬件资源无法共享、数据孤岛、应用孤岛等问题,导致资源浪费和管理效率低下。为此,智慧校园的建设目标聚焦于家校沟通便捷化、校园管理科学化、校园生活轻松化、课堂教学互动化和校园设施智能化,以提高教学效率和学生学习体验。 智慧校园的核心价值在于构建先进的网络教学平台和管理信息系统,实现教学资源的高效配置和利用,促进师生互动,提高管理效率,降低成本,构建健康高雅的生活环境。解决方案涵盖综合应用平台规划、系统架构设计、媒体发布、数字会议系统等,通过后台服务层、基础接入层和用户接入层的有机结合,实现智慧校园的全面功能。 智慧校园管理平台作为核心组成部分,提供模块化体系,包括公开课、直播、教学资源等23大应用,支持与第三方接口对接,实现多级管理。电教预约管理平台通过移动端APP或web后台简化预约流程,提高教室和会议室资源利用率,支持会议预订、审批、信息发布和环境管控。 教育录播系统和云平台支持教师制作和分享优质教学资源,进行在线组卷和评卷,同时提供学生应用,如高清视频录制、在线直播和互动交流,促进教学资源的共享和教育均衡化发展。这些系统的整合应用,将极大地推动教育信息化进程,实现教育资源的最大化利用和教育质量的全面提升。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值