1011 World Cup Betting (20 分)

1011 World Cup Betting (20 分)

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

题的意思就是选出美行中最大的一个数;

然后按照他给出的公式相乘;

第一列代表W,依次T,L;

#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
#include <iomanip>
using namespace std;

int main()
{
    vector <double> q;
    map <double,int> m1,m2,m3;
    double bet;
    int i,j;
    double max_p;
    int mbet4[4]= {0};
    map <double,int>::iterator it,mbet;
    for( i=0; i<3; i++)
    {
        max_p=-1;
        for( j=0; j<3; j++)
        {
            cin>>bet;
            if(i==0&&bet>max_p)
            {
                max_p=bet;
                m1[max_p]=j;
            }
            else if(i==1&&bet>max_p)
            {
                max_p=bet;
                m2[max_p]=j;
            }
            else
            {
                max_p=bet;
                m3[max_p]=j;
            }

        }
    }
    mbet=m1.begin();
    for(it=m1.begin(); it!=m1.end(); it++)
    {
        if(it->first>mbet->first)
            mbet=it;
    }
    max_p=1;
    mbet4[0] = mbet->second;
    max_p=max_p*mbet->first;
    mbet=m2.begin();
    for(it=m2.begin(); it!=m2.end(); it++)
    {
        if(it->first>mbet->first)
            mbet=it;
    }
    mbet4[1]=mbet->second;
    max_p=max_p*mbet->first;
    mbet=m2.begin();
    for(it=m3.begin(); it!=m3.end(); it++)
    {
        if(it->first>mbet->first)
            mbet=it;
    }
    mbet4[2]=mbet->second;
    max_p=max_p*mbet->first;
    for( i=0; i<3; i++)
    {
        if(mbet4[i]==0)
            cout<<'W'<<' ';
        if(mbet4[i]==1)
            cout<<'T'<<' ';
        if(mbet4[i]==2)
            cout<<'L'<<' ';
    }
    cout<<fixed<<setprecision(2)<<(max_p*0.65-1)*2;

}


这道题写的有点麻烦了,因为想练一下map的用法,就用了map;

本来想着把三个map里的最大值再合并一个map里;

但有可能map的second是一样的,就会覆盖;?(开始用三个map时就是想到了这一点,然后莫名其妙)

还是用了数组

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值