Digit sum-----The Preliminary Contest for ICPC Asia Shanghai 2019

A digit sum S_b(n)Sb(n) is a sum of the base-bb digits of nn. Such as S_{10}(233) = 2 + 3 + 3 = 8S10(233)=2+3+3=8, S_{2}(8)=1 + 0 + 0 = 1S2(8)=1+0+0=1, S_{2}(7)=1 + 1 + 1 = 3S2(7)=1+1+1=3.

Given NN and bb, you need to calculate \sum_{n=1}^{N} S_b(n)n=1NSb(n).

InputFile

The first line of the input gives the number of test cases, TT. TT test cases follow. Each test case starts with a line containing two integers NN and bb.

1 \leq T \leq 1000001T100000

1 \leq N \leq 10^61N106

2 \leq b \leq 102b10

OutputFile

For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 11) and yy is answer.

样例输入
2
10 10 8 2
样例输出
Case #1: 46
Case #2: 13
#include <stdio.h>

int main()
{
    long long t, tot, n, b, a[15], x, num, sum, i, j, N, temp;
    for(i=0;i<13;i++)
    {
        a[i] = i;
    }
    scanf("%lld", &t);
    tot = 0;
    while(t--)
    {
        scanf("%lld %lld", &n, &b);
        temp = (b-1)*b/2;
        x = 1;
        sum = 0;
        while(n>=x)
        {
            sum = sum + temp * x * (n / (x * b));
            N = n % (x * b);
            num = 0;
            for(j=0;j+x<=N;j+=x)
            {
                if(num==b) num = 0;
                sum = sum + a[num] * x;
                num++;
            }
            if(num==b) num=0;
            sum = sum + a[num]*(N-j+1);
            x *= b;
        }
        tot++;
        printf("Case #%lld: %lld\n", tot, sum);
    }
    return 0;
}

 

 

 

 



转载于:https://www.cnblogs.com/0xiaoyu/p/11528861.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值