7-24 First 50 Prime Numbers (10 分)

7-24 First 50 Prime Numbers

Your program reads one natural numbers n in, and prints out the sum of the first n prime numbers starting from 2.

输入格式:

A positive whole numbers n, which is less than 10
​3
​​ .

输出格式:

A number which is the sum of all the first n prime numbers.

输入样例:

10

输出样例:

129
import java.util.Scanner;
public class Main{
 public static void main(String[] args){
     Scanner cin=new Scanner(System.in);
     int n=cin.nextInt();
     int sum=0;
     int i=0;
     int x=2;
while(i!=n)
{
    if(is_prime(x))
    {
        sum+=x;
    i++;
    }
    x++;
    
}    
     System.out.print(sum);
   
 }
    public static boolean is_prime(int x)
    {
        for(int i=2;i*i<=x;i++)
        {
            if(x%i==0)
            {
                return false;
            }
        }
        return true; 
    }
}

这题倒不难主要是用英文出题唬住人,该题意思就是输出前N个质数之和,循环判断累加即可。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Hzhhn.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值