解决openssl错误导致centos 7无法安装 nginx

Linux 专栏收录该内容
32 篇文章 0 订阅

在centos7上由于openssl的版本低于nginx依赖的版本,导致无法安装 nginx错误,报如下错误

Error: Package: 1:nginx-1.12.2-2.el7.x86_64 (epel)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)

为解决这个问题,下载相关的rpm包,以x86_64为例,下载相对应的版本 openssl 和 openssl-libs,其他版本自行去 rpm search中心搜索:

wget ftp://ftp.pbone.net/mirror/ftp.centos.org/7.6.1810/os/x86_64/Packages/openssl-libs-1.0.2k-16.el7.x86_64.rpm
wget ftp://ftp.pbone.net/mirror/ftp.centos.org/7.6.1810/os/x86_64/Packages/openssl-1.0.2k-16.el7.x86_64.rpm
yum localinstall  openssl-1.0.2k-16.el7.x86_64.rpm openssl-libs-1.0.2k-16.el7.x86_64.rpm

如果 localinstall 有错,检查是否二者的版本一致,若匹配,则执行如下命令尝试

rpm -ivh --replacefiles xxx.rpm 
或者
yum update openssl
yum update openssl-libs

 

  • 0
    点赞
  • 0
    评论
  • 1
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值