HUST 1017 Exact cover (DLX模板题)

DESCRIPTION There is an N*M matrix with only 0s and 1s, (1 <= N,M <= 1000). An exact cover is a selection of rows such that every column has a 1 in exactly one of the selected rows. Try to find out the selected rows. INPUT There are multiply test cases. First line: two integers N, M; The following N lines: Every line first comes an integer C(1 <= C <= 100), represents the number of 1s in this row, then comes C integers: the index of the columns whose value is 1 in this row. OUTPUT First output the number of rows in the selection, then output the index of the selected rows. If there are multiply selections, you should just output any of them. If there are no selection, just output "NO". SAMPLE INPUT
6 7
3 1 4 7
2 1 4
3 4 5 7
3 3 5 6
4 2 3 6 7
2 2 7
SAMPLE OUTPUT
3 2 4 6
#include <iostream>
#include <string.h>
#include <stdio.h>
const int maxnode=100010;
const int maxm=1010;
const int maxn=1010;
struct DLX
{
    int n,m,size;
    int U[maxnode],D[maxnode],R[maxnode],L[maxnode],Row[maxnode],Col[maxnode];
    int H[maxn];//行头节点
    int S[maxm];//每列有多少个节点
    int ansd,ans[maxn];//如果有答案,则选了ansd行,具体是哪几行放在ans[ ]数组里面,ans[0~ansd-1];
    void init(int _n,int _m)
    {
        n=_n,m=_m;
        for(int i=0; i<=m; i++)
        {
            S[i]=0;
            U[i]=D[i]=i;//初始状态下,上下自己指向自己
            L[i]=i-1;
            R[i]=i+1;
        }
        R[m]=0,L[0]=m;
        size=m;//编号,每列都有一个头节点,编号1-m
        for(int i=1; i<=n; i++)
            H[i]=-1;//每一行的头节点
    }

    void link(int r,int c)//第r行,第c列
    {
        ++S[Col[++size]=c];//第size个节点所在的列为c,当前列的节点数++
        Row[size]=r;//第size个节点行位置为r
        D[size]=D[c];//下面这四句头插法(图是倒着的?)
        U[D[c]]=size;
        U[size]=c;
        D[c]=size;
        if(H[r]<0)
            H[r]=L[size]=R[size]=size;
        else
        {
            R[size]=R[H[r]];
            L[R[H[r]]]=size;
            L[size]=H[r];
            R[H[r]]=size;
        }
    }

    void remove(int c)//删除节点c,以及c上下节点所在的行,每次调用这个函数,都是从列头节点开始向下删除,这里c也可以理解为第c列
    {
        //因为第c列的列头节点编号为c
        L[R[c]]=L[c];
        R[L[c]]=R[c];
        for(int i=D[c]; i!=c; i=D[i])
            for(int j=R[i]; j!=i; j=R[j])
            {
                U[D[j]]=U[j];
                D[U[j]]=D[j];
                --S[Col[j]];
            }
    }

    void resume(int c)//恢复节点c,以及c上下节点所在的行(同上,也可以理解为从第c列的头节点开始恢复
    {
        for(int i=U[c]; i!=c; i=U[i])
            for(int j=L[i]; j!=i; j=L[j])
                ++S[Col[U[D[j]]=D[U[j]]=j]]; //打这一行太纠结了 T T
        L[R[c]]=R[L[c]]=c;
    }

    bool dance(int d)//递归深度
    {
        if(R[0]==0)
        {
            ansd=d;
            return true;
        }
        int c=R[0];
        for(int i=R[0]; i!=0; i=R[i])
            if(S[i]<S[c])
                c=i;
        remove(c);//找到节点数最少的列,当前元素不是原图上0,1的节点,而是列头节点
        for(int i=D[c]; i!=c; i=D[i])
        {
            ans[d]=Row[i];//列头节点下面的一个节点
            for(int j=R[i]; j!=i; j=R[j])
                remove(Col[j]);
            if(dance(d+1))//找到,返回
                return true;
            for(int j=L[i]; j!=i; j=L[j])
                resume(Col[j]);
        }
        resume(c);
        return false;
    }
}g;
int main()
{
    int N,M;
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        g.init(N,M);
        for(int i=1; i<=N; i++)
        {
            int cnt,j;
            scanf("%d",&cnt);
            while(cnt--)
            {
                scanf("%d",&j);
                g.link(i,j);
            }
        }
        if(g.dance(0)==false)
            printf("NO\n");
        else
        {
            printf("%d",g.ansd);
            for(int i=0; i<g.ansd; i++)
                printf(" %d",g.ans[i]);
            printf("\n");
        }
    }
    return 0;
}

转载于:https://www.cnblogs.com/MisdomTianYa/p/6581707.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值