Code[vs] 1083 Cantor表

题目描述 Description

现代数学的著名证明之一是Georg Cantor证明了有理数是可枚举的。他是用下面这一张表来证明这一命题的: 1/1 1/2 1/3 1/4 1/5 … 2/1 2/2 2/3 2/4 … 3/1 3/2 3/3 … 4/1 4/2 … 5/1 … … 我们以Z字形给上表的每一项编号。第一项是1/1,然后是1/2,2/1,3/1,2/2,…

输入描述 Input Description

整数N(1≤N≤10000000)

输出描述 Output Description

表中的第N项

样例输入 Sample Input

7

样例输出 Sample Output

1/4

#include <iostream>
#include <string>
#include <algorithm>
#include <stdio.h>
#include <math.h>
using namespace std;
int main()
{
    int N;
    cin>>N;
    long long Pai=int(sqrt(8*N+1)-1)/2;//算出是第几斜排
    long long ShengYu=N-Pai*(Pai+1)/2;
    int ant=ShengYu==0?Pai:Pai+1;
    if(ShengYu==0)ShengYu=ant;
    if(ant%2==0)
        cout<<(1+ShengYu-1)<<"/"<<(ant-ShengYu+1)<<endl;
    else
        cout<<(ant-ShengYu+1)<<"/"<<(1+ShengYu-1)<<endl;


    return 0;
}

转载于:https://www.cnblogs.com/MisdomTianYa/p/6581734.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值