第一届省赛 Ivan comes again! (set)

题目描述

The Fairy Ivan gave Saya three problems to solve (Problem F). After Saya finished the first problem (Problem H), here comes the second.
This is the enhanced version of Problem H.
There is a large matrix whose row and column are less than or equal to 1000000000. And there are three operations for the matrix:
1)
add : Mark an element in the matrix. The element wasn’t marked before it is marked.
2) remove : Delete an element’s mark. The element was marked before the element’s mark is deleted.
3) find : Show an element’s row and column, and return a marked element’s row and column, where the marked element’s row and column are larger than the showed element’s row and column respectively. If there are multiple solutions, return the element whose row is the smallest; and if there are still multiple solutions, return the element whose column is the smallest. If there is no solution, return -1.
Of course, Saya comes to you for help again.

输入

The input consists of several test cases.
The first line of input in each test case contains one integer N (0<N200000), which represents the number of operations.
Each of the next N lines containing an operation, as described above.
The last case is followed by a line containing one zero.

输出

For each case, print the case number (1, 2 …) first. Then, for each “find” operation, output the result. Your output format should imitate the sample output. Print a blank line after each test case.

示例输入

4
add 2 3
find 1 2
remove 2 3
find 1 2

0

示例输出

Case 1:
2 3
-1
 
  
#include <iostream>
#include <stdio.h>
#include <set>
#include <string.h>
using namespace std;


int main()
{
    int N,cases=1;
    while(cin>>N&&N!=0)
    {
        string str;
        pair<int,int> p;
        set< pair<int,int> >s;
        printf("Case %d:\n",cases++);
        while(N--)
        {
            cin>>str;
            scanf("%d%d",&p.first,&p.second);
            if(str=="add")
                s.insert(p);
            if(str=="remove")
                s.erase(p);
            if(str=="find")
            {
                set< pair<int,int> >::iterator it;
                it=s.lower_bound(p);
                for(; it!=s.end(); it++)
                {
                    if(it->first>p.first&&it->second>p.second)
                    {
                        printf("%d %d\n",it->first,it->second);
                        break;
                    }
                }
                if(it==s.end())
                   printf("-1\n");
            }
        }
        printf("\n");
    }
    return 0;
}
 
 

转载于:https://www.cnblogs.com/MisdomTianYa/p/6581762.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值