HDU 4716 Computer Graphics Problem (纯水题)

Description

In this problem we talk about the study of Computer Graphics. Of course, this is very, very hard. 
We have designed a new mobile phone, your task is to write a interface to display battery powers. 
Here we use '.' as empty grids. 
When the battery is empty, the interface will look like this: 
*------------*
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
*------------*

When the battery is 60% full, the interface will look like this: 
*------------*
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
*------------*

Each line there are 14 characters. 
Given the battery power the mobile phone left, say x%, your task is to output the corresponding interface. Here x will always be a multiple of 10, and never exceeds 100.
 

Input

The first line has a number T (T < 10) , indicating the number of test cases. 
For each test case there is a single line with a number x. (0 < x < 100, x is a multiple of 10)
 

Output

For test case X, output "Case #X:" at the first line. Then output the corresponding interface. 
See sample output for more details.
 

Sample Input

 
    
2 0 60
 

Sample Output

 
    
Case #1: *------------* |............| |............| |............| |............| |............| |............| |............| |............| |............| |............| *------------* Case #2: *------------* |............| |............| |............| |............| |------------| |------------| |------------| |------------| |------------| |------------| *------------*
#include <iostream>
using namespace std;

int main()
{
    int T,cases=1;
    cin>>T;
    while(T--)
    {
        int N;
        cin>>N;
        cout<<"Case #"<<cases++<<":"<<endl;
        cout<<"*------------*"<<endl;
        for(int i=100;i>N;i=i-10)
            cout<<"|............|"<<endl;
        for(int i=N;i>=10;i=i-10)
            cout<<"|------------|"<<endl;
        cout<<"*------------*"<<endl;
    }
    return 0;
}



转载于:https://www.cnblogs.com/MisdomTianYa/p/6581739.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值