HDU 2609 How many

https://cn.vjudge.net/problem/HDU-2609

题目

Give you n ( n < 10000) necklaces ,the length of necklace will not large than 100,tell me
How many kinds of necklaces total have.(if two necklaces can equal by rotating ,we say the two necklaces are some).
For example 0110 express a necklace, you can rotate it. 0110 -> 1100 -> 1001 -> 0011->0110.

Input

The input contains multiple test cases.

Each test case include: first one integers n. (2<=n<=10000)
Next n lines follow. Each line has a equal length character string. (string only include '0','1').

Output

For each test case output a integer , how many different necklaces.

Sample Input

4
0110
1100
1001
0011
4
1010
0101
1000
0001

Sample Output

1
2

题解

$\mathcal{O}(n)$贪心最小表示法,然后排序= =

虽然可以Hash+EXKMP判断,但是计算HASH时也需要最小表示法……

AC代码

#include<bits/stdc++.h>
#define REP(r,x,y) for(register int r=(x); r<(y); r++)
#define REPE(r,x,y) for(register int r=(x); r<=(y); r++)
#define PERE(r,x,y) for(register int r=(x); r>=(y); r--)
#ifdef sahdsg
#define DBG(...) printf(__VA_ARGS__), fflush(stdout)
#else
#define DBG(...) (void)0
#endif // sahdsg
using namespace std;
char buf[207];
inline void getmin(char *p, int l) {
	char *a=p, *b=p+1;
	while(a-p<l && b-p<l) {
		int i=0;
		while(i<l && a[i]==b[i]) i++;
		if(i==l) break;
		if(a[i]<b[i]) {
			b+=i+1;
		} else if(a[i]>b[i]) {
			a+=i+1;
		}
		if(a==b) b++;
	}
	if(a-b>0) a=b;
	memcpy(buf,a,l);
	memcpy(p,buf,l); p[l]=0;
}
char s[10007][207];
int z[10007];
int l;
inline bool cmp(int a, int b) {
	return strcmp(s[a],s[b])<0;
}
inline bool eq(int a, int b) {
	return strcmp(s[a],s[b])==0;
}
int main() {
	int n;
	while(~scanf("%d", &n)) {
		REP(i,0,n) {
			scanf("%s", s[i]);
			z[i]=i;
			if(!i) l=strlen(s[0]);
			memcpy(s[i]+l,s[i],l); s[i][l<<1]=0;
			getmin(s[i],l);
		}
		sort(z,z+n,cmp);
		printf("%d\n", unique(z,z+n,eq)-z);
	}
}

 

转载于:https://www.cnblogs.com/sahdsg/p/10901814.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值