7-6 sdut-常用类-骄傲的代价分数 10

E_star由于在上次考试中取得了很好的成绩他开始骄傲起来,此时von看不下去了,于是他把E_star叫来说,最近一道A+B编程题目不会,想让E_star来帮他解答,E_star二话没说结一口答应了,等到von把题目发给E_star的时候他傻眼了。这下,知道骄傲的后果了吧。

JAVA语言实现提示:可使用JDK标准API中的类:java.math.BigInteger。

输入格式:

题目有多组数据,处理到文件结束。输入的第一行包含一个数T,代表测试组数;

接下来有T行,每行有两个整数A和B,中间用空格分隔。

提示:整数可能超出long类型的取值范围。B不为0。

输出格式:

对于每一组数据,输出5行数据,分别为2个数的和、差、积、商(整除)、余数。形式为:

A+B=C,其中C是A与B的加和。

A-B=D,其中D是A与B的差。

A*B=E,其中E是A与B的乘积。

A/B=F,其中F是A与B的商(整数)。

A%B=G,其中G是A除以B的余数。

输入样例:

3
1 2
24 6
12313131231231232131 31232131315465436657434321

输出样例:

1+2=3
1-2=-1
1*2=2
1/2=0
1%2=1
24+6=30
24-6=18
24*6=144
24/6=4
24%6=0
12313131231231232131+31232131315465436657434321=31232143628596667888666452
12313131231231232131-31232131315465436657434321=-31232119002334205426202190
12313131231231232131*31232131315465436657434321=384565331518372453687453692411523206037368051
12313131231231232131/31232131315465436657434321=0
12313131231231232131%31232131315465436657434321=12313131231231232131
//package shiyan01.demo01;
import java.util.Scanner;
import java.math.BigInteger;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        Compute co = new Compute();
        int n;
        BigInteger x,y;
        n = sc.nextInt();
        for (int i = 0; i < n; i++) {
            x = sc.nextBigInteger();
            y = sc.nextBigInteger();
            System.out.println(x+"+"+y+"="+co.addition(x,y));
            System.out.println(x+"-"+y+"="+co.subtraction(x,y));
            System.out.println(x+"*"+y+"="+co.multiplication(x,y));
            System.out.println(x+"/"+y+"="+co.division(x,y));
            System.out.println(x+"%"+y+"="+co.remainder(x,y));
        }
    }
}

class Compute {
    private BigInteger x,y,ra,rj,rm,rd,rs;
    public BigInteger addition(BigInteger x,BigInteger y) {
        ra = x.add(y);
        return ra;
    }
    public BigInteger subtraction (BigInteger x,BigInteger y) {
        rj = x.subtract(y);
        return rj;
    }
    public BigInteger multiplication(BigInteger x,BigInteger y) {
        rm = x.multiply(y);
        return rm;
    }
    public BigInteger division(BigInteger x,BigInteger y) {
        rd = x.divide(y);
        return rd;
    }
    public BigInteger remainder(BigInteger x,BigInteger y) {
        rs = x.remainder(y);
        return rs;
    }
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值