HDU 3631 Shortest Path

When YY was a boy and LMY was a girl, they trained for NOI (National Olympiad in Informatics) in GD team. One day, GD team’s coach, Prof. GUO asked them to solve the following shortest-path problem.
There is a weighted directed multigraph G. And there are following two operations for the weighted directed multigraph:
(1) Mark a vertex in the graph.
(2) Find the shortest-path between two vertices only through marked vertices.
For it was the first time that LMY faced such a problem, she was very nervous. At this moment, YY decided to help LMY to analyze the shortest-path problem. With the help of YY, LMY solved the problem at once, admiring YY very much. Since then, when LMY meets problems, she always calls YY to analyze the problems for her. Of course, YY is very glad to help LMY. Finally, it is known to us all, YY and LMY become programming lovers.
Could you also solve the shortest-path problem?

Input

The input consists of multiple test cases. For each test case, the first line contains three integers N, M and Q, where N is the number of vertices in the given graph, N≤300; M is the number of arcs, M≤100000; and Q is the number of operations, Q ≤100000. All vertices are number as 0, 1, 2, … , N - 1, respectively. Initially all vertices are unmarked. Each of the next M lines describes an arc by three integers (x, y, c): initial vertex (x), terminal vertex (y), and the weight of the arc (c). (c > 0) Then each of the next Q lines describes an operation, where operation “0 x” represents that vertex x is marked, and operation “1 x y” finds the length of shortest-path between x and y only through marked vertices. There is a blank line between two consecutive test cases.
End of input is indicated by a line containing N = M = Q = 0.

Output

Start each test case with "Case #:" on a single line, where # is the case number starting from 1.
For operation “0 x”, if vertex x has been marked, output “ERROR! At point x”.
For operation “1 x y”, if vertex x or vertex y isn’t marked, output “ERROR! At path x to y”; if y isn’t reachable from x through marked vertices, output “No such path”; otherwise output the length of the shortest-path. The format is showed as sample output.
There is a blank line between two consecutive test cases.

Sample Input

5 10 10
1 2 6335
0 4 5725
3 3 6963
4 0 8146
1 2 9962
1 0 1943
2 1 2392
4 2 154
2 2 7422
1 3 9896
0 1
0 3
0 2
0 4
0 4
0 1
1 3 3
1 1 1
0 3
0 4
0 0 0

Sample Output

Case 1:
ERROR! At point 4
ERROR! At point 1
0
0
ERROR! At point 3
ERROR! At point 4

 

题意:在一个有向图上有两种操作,一种是把某个点标记,另一种是求两个标记过的点经过标记过的点的最短距离。

解题思路:

我每标记一个点 我就以这个点更新一下两点之间经过这个标记过的点的最短距离。如果题目询的起点和终点都被标记过了,那么我们就能使用这个更新后的最小距离。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=1e3+10;
const int inf=0x3f3f3f3f;
int n,m,mp[maxn][maxn],mark[maxn],q; 
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))
void init(){
	int i,j;
	for(i=0;i<n;i++){
		mark[i]=0;mp[i][i]=0;
		for(j=i+1;j<=n;j++){
			mp[i][j]=mp[j][i]=inf;
		}
	} 
}
void floy(int k){
	int i,j;
	for(i=0;i<n;i++){
		if(i==k) continue;
		for(j=0;j<n;j++){
			if(i==j||j==k) continue;
			if(mp[i][j]>mp[i][k]+mp[k][j]){
				mp[i][j]=mp[i][k]+mp[k][j];
			} 
		}
	}
}
int main(){
	int i,j,cas=1,flag=0;
	while(scanf("%d%d%d",&n,&m,&q)!=EOF){
		if(n+m+q==0) break;
		if(flag) printf("\n");
		flag=1;
		init();
		int u,v,w;
		for(i=0;i<m;i++){
			scanf("%d%d%d",&u,&v,&w);
			if(mp[u][v]>w) mp[u][v]=w;
		}
		printf("Case %d:\n",cas++);
		while(q--){
			scanf("%d%d",&u,&v);
			if(u==0){
				if(mark[v]) printf("ERROR! At point %d\n",v);
				else mark[v]=1,floy(v);
			}
			else{
				scanf("%d",&w);
				if(!mark[v]||!mark[w]) printf("ERROR! At path %d to %d\n",v,w);
				else{
					if(mp[v][w]<inf) printf("%d\n",mp[v][w]);
					else printf("No such path\n");
				}
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值