POJ 2828 Buy Tickets(线段树)

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 21921 Accepted: 10747

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi andVali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

题意:一个插队问题,后面来的人可以插在队伍当中,求最后队伍的状态。
思路:因为后面来的人可以插队会改变队伍的状态,但是我们知道最后一个人肯定是到自己要去的位置。所以我们可以通过逆向思维反方向来还原队伍状态,我们可以建立一棵线段树储存区间内的空位。每一次插入之后都更新区间剩余空位,把已经插入的数忽略,将剩下的数当做一个新的集合,剩余的空位都对应剩下的数。这样每一次插入数字都可以当做第一次插入数字。在更新插入节点的时候为了保证能够将数字插入到正确的位置,先判断左子树的剩余空位,若左子树剩余空位不足,将要插入元素的位置减去左子树的空位,再继续从右子树当中找要插入的位置。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int MAXN=200000+10;
struct node
{
    int l,r;
    int w;//区间内的剩余空位
}segTree[4*MAXN];
int a[MAXN],pos[MAXN],val[MAXN];
int id;

void build(int root,int l,int r)
{
    segTree[root].l=l;
    segTree[root].r=r;
    segTree[root].w=r-l+1;
    if(l==r)
        return;
    int mid=(l+r)>>1;
    build(root<<1,l,mid);
    build(root<<1|1,mid+1,r);

}

void update(int root,int x)
{
    segTree[root].w--;//插入数字的话空位减1,当然也可以回溯来更新空位的个数
    if(segTree[root].l==segTree[root].r)
    {
        //找到插入的位置
       id=segTree[root].l;
       return;
    }
    //如果左子树剩余空位足够的话,在左子树里面找
    if(segTree[root<<1].w>=x)
        update(root<<1,x);
    else
    {
        //当左子树的剩余空位不足的时候,更新x的值来保证在右子树当中找到正确位置
        x-=segTree[root<<1].w;
        update(root<<1|1,x);
    }
}

int main()
{
    int n,i;
    while(scanf("%d",&n)!=EOF)
    {
        build(1,1,n);
        for(i=1;i<=n;i++)
            scanf("%d %d",&pos[i],&val[i]);
        for(i=n;i>=1;i--)
        {
            update(1,pos[i]+1);
            a[id]=val[i];
        }
        for(i=1;i<=n;i++)
            printf("%d ",a[i]);
        printf("\n");

    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值