HDU 3033 I love sneakers!(分组背包)

I love sneakers!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6928    Accepted Submission(s): 2825


 

Problem Description

After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.


There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.

 

 

Input

Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.

 

 

Output

For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.

 

 

Sample Input

 

5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66

 

 

Sample Output

 

255

 

 

Source

2009 Multi-University Training Contest 13 - Host by HIT

 

 

Recommend

gaojie   |   We have carefully selected several similar problems for you:  2955 2159 1561 1171 1203 

题意:一些鞋子有k种品牌,第k种牌子的鞋子里面有一些品种不同的鞋子,每种都有自己的价格和价值,收藏家有m元想收集每种品牌的鞋子至少一双(但是相同品牌相同品种的鞋他只要一双),问他总共可以收集多少价值的鞋子。

思路:普通的分组背包是一组当中只能选一件,这里一组当中可以选择多件,那么有两种情况,第一种情况就是第一次选本组的物品,那么状态就是从上一组转移来的;另外如果不是第一次选本组的物品,那么就是从本组转移来的。一组里面如何选多件物品呢?把分组背包的最后两重循环调换一下即可。注意初始化问题,因为转移有合法与不合法之分,所以初始化为-1。

#include<bits/stdc++.h>
using namespace std;
int dp[15][10005];
int main()
{
    int a[105],n,m,c[105],w[105],k;
    while(scanf("%d%d%d",&n,&m,&k)!=EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d %d %d",&a[i],&c[i],&w[i]);
        }
        memset(dp,-1,sizeof(dp));
        for(int i=0;i<=m;i++)
            dp[0][i]=0;
        for(int i=1;i<=k;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(a[j]==i)
                {
                    for(int p=m;p>=c[j];p--)
                    {
                        if(dp[i][p-c[j]]!=-1)
                            dp[i][p]=max(dp[i][p],dp[i][p-c[j]]+w[j]);
                        if(dp[i-1][p-c[j]]!=-1)
                            dp[i][p]=max(dp[i][p],dp[i-1][p-c[j]]+w[j]);
                    }
                }
            }
        }
        if(dp[k][m]==-1)
            printf("Impossible\n");
        else
            printf("%d\n",dp[k][m]);
    }
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值