排序与sort函数的应用 PAT A1025 Ranking 全网最详解析 附完整代码 PAT真题解析

本篇文章将会用一道PAT甲级(A1025)题目,完整讲述sort函数的应用

首先,上题目:PAT A1025【 PAT Ranking】

注释很重要一定要认真看
注释很重要一定要认真看
注释很重要一定要认真看

题目要求:

​ Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

有n个考场,每个考场有若干数量的考生。现在给出各个考场中考生的准考证号与分数,要求将所有考生按分数从高到低排序,并按顺序输出所有考生的准考证号、排名、考场号以及考场内排名。

Input Specification:(输入格式)

​ Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.(翻译见输入样例)

Output Specification:(输出格式)

​ For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

​ registration_number final_rank location_number local_rank

​ The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.(翻译见输出样例)

Sample Input:(输入样例)

2		// 考场个数
5		// 第一个考场的考生数
1234567890001 95		// 考生准考证号  分数
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4		// 第二个考场的考生数
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:(输出样例)

9		// 考生总人数
1234567890005 1 1 1		//考生准考证号  总排名  考场号  考场排名
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

解题思路:

毋庸置疑,本程序需要用到结构体,在结构体变量中,我们存放题目要求的如下信息:

struct Student {	//学生信息结构体
	char id[15];			//准考证号
	int score;				//分数
	int location_number;	//考场号
	int local_rank;			//考场内排名
    //这里也可以加一个总排名的字段,但题目没有要求,我们就可以直接在输出的时候计算总排名。
}

并且根据题意和输入输出样例我们得知,在该程序中我们需要 计算 / 输出 如下信息:

  1. 考生总人数
  2. 每个考生的考场号(考场号从1开始,按输入顺序记录)
  3. 每个考生在其所在考场的排名
  4. 每个考生在全部考生中的排名

(若对sort函数不了解的同学请先百度进行学习,很容易看懂)

根据题目要求,很显然默认的排序算法已经不能满足我们对结构体中分数进行排序的要求,所以我们需要写一个排序函数cmp,规则如下。

​ ① 当分数不同时,按分数从大到小排序。

​ ② 否则(当分数相同时),按准考证号从小到大排序

bool cmp(Student a, Student b) {
	if(a.score != b.score) return a.score > b.score;	//先按分数从高到低排序
	else return strcmp(a.id, b.id) < 0;		//分数相同按准考证号从小到大排序
}

注意:排序完成后,我们得到的必定是按分数降序排列的一组结构体(这也方便我们直接输出)

在写程序之前,我们先思考一下整个算法会分为几个部分:

  1. 按考场读入各考生的信息,并对当前读入考场的所有考生进行排序。之后将该将该考场的所有考生的排名写入他们的结构体中。
  2. 对所有考生进行排序。
  3. 按顺序一边计算总排名,一边输出所有考生的信息。

注意:对同一考场的考生单独排序的方法:定义int型变量num,用来存放当前获取到的考生人数。初始值为0,每读入一个考生的信息,就让num自增,这样当读取完一个考场的考生信息(假设该考场有k个考生)后,这个考场的考生所对应的数组下标便为区间 [num - k, num)。

程序实现:

在main函数中,分为两步:①计算 ②输出,我们先看第一步

int n, k, num = 0;				//n为考场数 k为某个考场的考生数 num为考生总数
	scanf("%d", &n);			//输入考场数n
	for(int i = 1; i <= n; i++){
		scanf("%d",&k);			//输入该考场的考生数n
		for(int j = 1; j <= k; j++) {
			scanf("%s %d",stu[num].id, &stu[num].score);
			stu[num].location_number = i;	//该考生的考场号为i
			num++;							//总考生数加1
		}
		sort(stu + num - k, stu + num, cmp);	//将该考场的考生排序
		stu[num - k].local_rank = 1;		//将该考场第1名的local_rank标记为1
		for(int j = num - k + 1; j < num; j++) {	//对该考场剩余的考生
			if(stu[j].score == stu[j - 1].score){	//如果与前一位考生同分
				//local_rank 也相同
				stu[j].local_rank = stu[j-1].local_rank;
			} else {	//如果与前一位考生不同分
				//local_rank 为该考生前的人数
                //这里是重点,可能很难理解,多思考一下
                //该考场的考生所对应的数组下标应该为区间 [num - k, num),num - k是起始
                //我们将该考场的第一名学生的排名标记为1,也就是说在循环时跳过了第一名学生
                //而 j 代表的是当前考生之前的总人数(包括已经统计的其他考场)
                //所以该考生在本考场前的人数应该是:j - (num - k) 最后加上跳过的第一名学生
				stu[j].local_rank = j - (num - k) + 1;
			}
		}
	}

②输出,这里没什么难度,计算排名的方法跟上面类似。

	printf("%d\n", num);			//输出考生总数
	sort(stu, stu + num, cmp);		//将所有考生排序
	int r = 1;						//当前考生的排名
	for(int i = 0; i < num; i++) {
		if(i > 0 && stu[i].score != stu[i - 1].score) {
			r = i + 1;		//当前考生与上一个考生分属不同时,让r更新为人数+1
		}
		printf("%s ", stu[i].id);
		printf("%d %d %d\n", r, stu[i].location_number, stu[i].local_rank);
	}

至此,所有已经能按照题目要求排序输出了。

最后附上完整代码

#include <cstdio>
#include <cstring>		//用于使用strcmp函数
#include <algorithm>
using namespace std;

struct Student {
	char id[15];			//准考证号
	int score;				//分数
	int location_number;	//考场号
	int local_rank;			//考场内排名
}stu[30010];

bool cmp(Student a, Student b) {
	if(a.score != b.score) return a.score > b.score;	//先按分数从高到低排序
	else return strcmp(a.id, b.id) < 0;		//分数相同按准考证号从小到大排序
}

int main() {
	
	int n, k, num = 0;		//n为考场数 k为某个考场的考生数 num为考生总数
	scanf("%d",&n);			//输入考场数n
	for(int i = 1; i <= n; i++){
		scanf("%d",&k);		//输入该考场的考生数n
		for(int j = 1; j <= k; j++){
			scanf("%s %d",stu[num].id, &stu[num].score);
			stu[num].location_number = i;	//该考生的考场号为i
			num++;							//总考生数加1
		}
		sort(stu + num - k, stu + num, cmp);	//将该考场的考生排序
		stu[num - k].local_rank = 1;		//将该考场第1名的local_rank标记为1
		for(int j = num - k + 1; j < num; j++) {	//对该考场剩余的考生
			if(stu[j].score == stu[j - 1].score){	//如果与前一位考生同分
				//local_rank 也相同
				stu[j].local_rank = stu[j-1].local_rank;
			} else {	//如果与前一位考生不同分
				//
				stu[j].local_rank = j - (num - k) + 1;
			}
		}
	}
	printf("%d\n", num);		//输出考生总数
	sort(stu, stu + num, cmp);	//将所有考生排序
	int r = 1;					//当前考生的排名
	for(int i = 0; i < num; i++) {
		if(i > 0 && stu[i].score != stu[i - 1].score) {
			r = i + 1;		//当前考生与上一个考生分属不同时,让r更新为人数+1
		}
		printf("%s ", stu[i].id);
		printf("%d %d %d\n", r, stu[i].location_number, stu[i].local_rank);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值