hdu1222-Wolf and Rabbit

Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2960 Accepted Submission(s): 1628
 
Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
 
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
 
Output

            For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
 
Sample Input
2
1 2
2 2
 
Sample Output
NO
YES
 

说一下我的思路,如果是模拟的话,肯定是会超时的,毕竟数字的范围有0x7fffffff那么大,那么有什么规律呢?
下面是我的思路:
①首先这个问题可以看成是一个变种的约瑟夫环问题,即是否到最后会遍历完所有的人。
②设在N个点的圈中,按每数M个标记一下,那么能够把所有的点遍历到即要满足在循环完一圈后,新的起点一定要在1-M中的任何一点出现一次,这个不难理解吧。那么问题就转化为能否遍历1-M中所有的点,依次如此进行下去,当发现不能满足小区间的要求时,那么其父层亦不能满足要求。那么每次起点的偏移量是否有规律呢?答案是有的,以初始的N和M为例,每次的偏移量是 N%M( 假设N> M反之交换位置 ),也即取余的一个过程,那么接下来的新的N就是M,M也就变成了 N%M, 即 N2<-- M1;  M2<-- N1% M1;我们设想当N 不为1,而偏移量M又已经为0,那么整个样例也就不可能做到一一查询了。      哦哦,这就是 闻名遐迩的 gcd。
(上面是我抄别人的一段话,我发现自己讲的比较的啰嗦,而且不是很清楚,所以就借用原话了~)

下面是AC代码:
#include <bits/stdc++.h>
using namespace std;

typedef long long LL;

LL gcd(int a, int b){
    if (!b){
        return a;
    }
    else
        return gcd(b, a%b);
}

int main()
{
    int T;
    cin>>T;
    while(T--){
        int n, m;
        cin>>m>>n;
        if (gcd(n, m) == 1){
            cout<<"NO"<<endl;
        }
        else
            cout<<"YES"<<endl;

    }
    return 0;
}

最后是无关紧要的仅仅对自己的提醒:不妨回顾一下约瑟夫环问题的数学递推过程?
f [1] = 0;//这里最开始的遍历是从0开始的,所以当剩下最后一个人的时候,他的编号就是0;
f[n] = (f[n-1]+m)%n;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值