字符串排序

Problem Description
输入3个字符串,按字典序从小到大进行排序。
Input
输入数据有一行,分别为3个字符串,用空格分隔,每个字符串长度不超过100。
Output
输出排序后的三个字符串,用空格分隔。
Example Input
abcd cdef bcde
Example Output

abcd bcde cdef



#include<stdio.h>  
#include<string.h>  
int main()  
{  
    char a[101],b[101],c[101],t[101],max[101],min[101];  
    scanf("%s%s%s",&a,&b,&c);  
    strcpy(max,a),strcpy(min,a);  
    if(strcmp(b,max)>0)  
        strcpy(max,b);  
    else if(strcmp(c,max)>0)  
        strcpy(max,c);  
    else if(strcmp(b,min)<0)  
        strcpy(min,b);  
    if(strcmp(c,min)<0)  
        strcpy(min,c);  
    if(strcmp(a,max)!=0&&strcmp(a,min)!=0)  
        strcpy(t,a);  
    else if(strcmp(b,max)!=0&&strcmp(b,min)!=0)  
        strcpy(t,b);  
    else if(strcmp(c,max)!=0&&strcmp(c,min)!=0)  
        strcpy(t,c);  
    printf("%s %s %s\n",min,t,max);  
    getchar();  
    return 0;  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值