POJ 1308 Is It A Tree?

题目描述:

http://ac.jobdu.com/problem.php?pid=1481

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

输入:

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero and less than 10000.

输出:

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

样例输入:
6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1
样例输出:
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
/*
*这个是采用并查集 + 判入度的方法来实现的
*连通且最多有一个点的入度为0 其他的入度都是1
*/
#include <cstdio>
#include <string.h>
#define N 10000

//保存入度
int degree[10001];
//并查集
int tree[10001];
//标记顶点是否出现,从而计算顶点个数
bool mark[10001];
int find(int x){
	if(tree[x] == -1)
		return x;
	else{
		int tmp = find(tree[x]);
		tree[x] = tmp;
		return tmp;
	}
}

int main(){
	int n, m, a, b, ve, ed, de, ca = 1;
	bool yes;
	while(~scanf("%d%d", &a, &b) && !(a == -1 && b == -1)){
		memset(tree, -1, sizeof(tree));
		memset(degree, 0, sizeof(degree));
		memset(mark, false, sizeof(mark));
		ve = 0;//顶点个数
		ed = 0;//计算非根节点的个数
		de = 0;//入度为1的顶点个数
		yes = true;//开始设为树
		//判断是不是一上来就是0 0,此时为空树
		if(a == 0 && b == 0){
			printf("Case %d is a tree.\n" , ca++);
			continue;
		}
		do{
			degree[b]++;//入度+1
			//如果顶点不存在,标记存在 顶点个数 + 1
			if(!mark[a]){
				ve++;
				mark[a] = true;
			}
			if(!mark[b]){
				ve++;
				mark[b] = true;
			}
			a = find(a);
			b = find(b);
			if(a != b){
				tree[b] = a;
			}
			scanf("%d%d", &a, &b);
		}while(!(!a && !b));
		for(int i = 1; i <= N; i++)
			if(tree[i] != -1)
				ed++;
		for(int i = 1; i <= N; i++){
			if(degree[i] == 1)
				de++;
			if(degree[i] > 1)
				yes = false;
		}
		if(ve != ed + 1 || ed != de)
			yes = false;
		yes ? printf("Case %d is a tree.\n" , ca++) :printf("Case %d is not a tree.\n", ca++);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值