HDU 1015 深搜

Description

=== Op tech briefing, 2002/11/02 06:42 CST === 
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below." 

Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Output

LKEBA
YOXUZ
GHOST
no solution

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Sample Output

LKEBA
YOXUZ
GHOST
no solution

题意:已知每行一个整数target 一个字符串s; 在s中查找到5个字母对应的数值

            按照 v - w^2 + x^3 - y^4 + z^5 = target 的规定,输出字典序最大的五个字母;两个条件;
分析:按照一定方式搜索某个结果,搜索问题; 深搜问题
           注意字典序顺序,(直接从26或者25开始查找,这样避免判断字典序顺序的问题比较简便)
           注意到有的字母已知中没有给,所以需要数组利用循环对出现的字母标记1;
           在从大到小搜索中,直接进行判断,赋值,标记,递归,回溯;
           dfs结果的判断,直接输出,注意细节;
           还有另外方法:对满足条件的字符串进行比较,找到最大字符串才输出     
注意:标记数组,dfs搜索中,数组变量的变化(是否加一);

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>

using namespace std;
int n,flag;
int a[6],v[30],c[30];
char s[30];
void dfs(int k)
{
    if(flag)
        return;
    if(k==5)    //找到5个数;
    {
        //int sum=a[1]-a[2]*a[2]+a[3]*a[3]*a[3]-a[4]*a[4]*a[4]*a[4]+a[5]*a[5]*a[5]*a[5]*a[5];
        int sum=a[0]-a[1]*a[1]+a[2]*a[2]*a[2]-a[3]*a[3]*a[3]*a[3]+a[4]*a[4]*a[4]*a[4]*a[4];
        // int sum=a[0]-pow(a[1],2)+pow(a[2],3)-pow(a[3],4)+pow(a[4],5);
        if(sum==n)      //判断直接输出来
        {
            flag=1;
            printf("%c%c%c%c%c\n",a[0]+'A'-1,a[1]+'A'-1,a[2]+'A'-1,a[3]+'A'-1,a[4]+'A'-1);  //输出减一;
            return;   //结束函数;
        }
        return ;    //不能少,return
    }
    for(int i=25; i>=0; i--)   //从25~0;
    {
        if(v[i]==0&&c[i]==1)   //存在这个字母,并且没有用过;
        {
            v[i]=1;            //标记用过;
            a[k]=i+1;          //i从0开始,数值不能为0,故整体都加一,输出时应整体都减一;
            dfs(k+1);          //dfs深搜递归;  k为k+1;必须在dfs中加一;
            v[i]=0;            //回溯;
        }
    }
    return;//可有可无;
}
int main ()
{
    while(~scanf("%d%s",&n,s))
    {
        if(n==0&&strcmp(s,"END")==0)     //strcmp结束运行,用s=="END"不行;
            break;
        flag=0;
        memset(v,0,sizeof(v));
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        for(int i=0; s[i]!='\0'; i++)   //题意是找到最大的字母,dfs中直接从25开始;考虑某字母不存在必要情况,故此数组用来标记字母是否出现;
            c[s[i]-'A']=1;              //从0~25;
        dfs(0);                         //从0到5;
        if(flag==0)                     //另一种情况;
            printf("no solution\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值