springboot 启动报错 NoSuchMethodError: org.springframework.boot.builder.SpringApplicationBuilder.<init>

springboot 与 springcloud 版本不对应导致启动报错: java.lang.NoSuchMethodError: org.springframework.boot.builder.SpringApplicationBuilder.<init>([Ljava/lang/Object;)V

原因:

springboot 与 springcloud 版本不对应。

举例:springboot 版本为 <version>2.1.0.RELEASE</version> ,需要与 springcloud 版本 <version>Greenwich.SR2</version> 有对应关系。

<parent>
    <groupId>org.springframework.boot</groupId>
    <artifactId>spring-boot-starter-parent</artifactId>
    <version>2.1.0.RELEASE</version>
</parent>


<dependencyManagement>
    <dependencies>
        <dependency>
        <groupId>org.springframework.cloud</groupId>
        <artifactId>spring-cloud-dependencies</artifactId>
        <version>Greenwich.SR2</version>
        <type>pom</type>
        <scope>import</scope>
       </dependency>
    </dependencies>
</dependencyManagement>

 

转自: https://www.cnblogs.com/muxi0407/p/11652783.html    

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页