hdoj1532Drainage Ditches(网络流)

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9176    Accepted Submission(s): 4303


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
 

Sample Input
  
  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
  
  
50
 

Source
 

Recommend
lwg   |   We have carefully selected several similar problems for you:  1533 3338 1569 3572 3416 
 

刚学网络流,这题用了两种方法敲了下,这是网络流入门的好题

ford_fulkerson和dinic

自己感觉还是 dinic效率高些



#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <climits>
#include <vector>
#include <queue>
#include <cstdlib>
#include <string>
#include <set>
#include<stack>
using namespace std;
const int inf=10000000;
const int N=210;
struct edge{int to,cap,res;};
vector<edge> g[N];
int iter[N];
int level[N];
void init()
{
    for(int i=0;i<N;i++)
        g[i].clear();
}
void bfs(int s)
{
    memset(level,-1,sizeof(level));
    level[s]=0;
    queue<int> q;
    q.push(s);
    while(!q.empty())
    {
        int u=q.front();q.pop();
        for(int i=0;i<g[u].size();i++)
        {
            edge &e=g[u][i];
            if(e.cap>0&&level[e.to]<0)
            {
                level[e.to]=level[u]+1;
                q.push(e.to);
            }
        }
    }
}
int dfs(int s,int t,int f)
{
    if(s==t) return f;
    for(int &i=iter[s];i<g[s].size();i++)      // 这里用i=0开始也可以,不过这样可以优化一下
    {
        edge &e=g[s][i];
        if(e.cap>0&&level[e.to]>level[s])
        {
            int d=dfs(e.to,t,min(f,e.cap));
            if(d>0)
            {
                e.cap-=d;
                g[e.to][e.res].cap+=d;
                return d;
            }
        }
    }
    return 0;
}
void add_edge(int from,int to,int cost)
{
    edge tmp;
    tmp.to=to;tmp.cap=cost;tmp.res=g[to].size();
    g[from].push_back(tmp);
    tmp.to=from;tmp.cap=0;tmp.res=g[from].size()-1;
    g[to].push_back(tmp);
}
int max_flow(int s,int t)
{
    int ans=0;
    for(;;)
    {
        bfs(s);
        if(level[t]<0) return ans;
        memset(iter,0,sizeof(iter));
        while(1)
        {
            int f=dfs(s,t,inf);
            if(f>0) ans+=f;
            else break;
        }
    }
}
int main()
{
    int e,v;
    while(scanf("%d%d",&e,&v)!=EOF)
    {
        init();
        for(int i=0;i<e;i++)
        {
            int aa,bb,cc;
            scanf("%d%d%d",&aa,&bb,&cc);
            add_edge(aa,bb,cc);
        }
        printf("%d\n",max_flow(1,v));
    }
    return 0;
}







#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <climits>
#include <vector>
#include <queue>
#include <cstdlib>
#include <string>
#include <set>
#include<stack>
using namespace std;

const int N=210;
int used[N];
struct edge{int to,cap,res;};
const int inf=10000000;
vector<edge> g[N];
int dfs(int s,int t,int f)
{
    used[s]=1;
    if(s==t) return f;
    for(int i=0;i<g[s].size();i++)
    {
        edge &e=g[s][i];
        if(e.cap>0&&!used[e.to])
        {
            int d=dfs(e.to,t,min(f,e.cap));
            if(d>0)
            {
                e.cap-=d;
                g[e.to][e.res].cap+=d;
                return d;
            }
        }
    }
    return 0;
}
void init()
{
    for(int i=0;i<N;i++)
        g[i].clear();
}
void add_edge(int from,int to,int cost)
{
    edge tmp;
    tmp.to=to;tmp.cap=cost;tmp.res=g[to].size();      //这里要好好理解一下
    g[from].push_back(tmp);
    tmp.to=from;tmp.cap=0;tmp.res=g[from].size()-1;
    g[to].push_back(tmp);
}
int max_flow(int s,int t)
{
    int ans=0;
    for(;;)
    {
        memset(used,0,sizeof(used));
        int f=dfs(s,t,inf);
        if(f<=0)
        return ans;
        ans+=f;
    }
}
int main()
{
    int v,e;
    while(scanf("%d%d",&e,&v)!=EOF)
    {
        init();
        for(int i=0;i<e;i++)
        {
            int aa,bb,cc;
            scanf("%d%d%d",&aa,&bb,&cc);
            add_edge(aa,bb,cc);
        }
        printf("%d\n",max_flow(1,v));
    }
    return 0;
}






























































评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值