算法学习【14】—— 1190. Reduced ID Numbers

题目来源:http://soj.me/1190

1190. Reduced ID Numbers

Constraints

Time Limit: 2 secs, Memory Limit: 32 MB

Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8

思路:

这个看懂题目应该就OK的了,太久没敲代码,结果WA了一次student数组没有剩余。暴力搜索吧。

代码:

/*
Problem link: http://soj.me/1190
Author: BetaBin
Date: 2012/07/25
*/
#include <stdio.h>
#include <memory.h>

int students[302];
bool buckets[1000000];
int studentNum;
int groupNum;
int answer;

bool Test(int target)
{
    int remainder;
    memset(buckets, false, sizeof(bool) * answer);
    for(int i = 0; i < studentNum; ++i)
    {
        remainder = students[i] % target;
        if(buckets[remainder])
        {
            return false;
        }
        else
        {
            buckets[remainder] = true;
        }
    }
    return true;
}

int main()
{
    scanf("%d", &groupNum);
    while(groupNum--)
    {
        scanf("%d", &studentNum);
        for(answer = 0; answer < studentNum; ++answer)
        {
            scanf("%d", &students[answer]);
        }
        while(!Test(answer))
        {
            ++answer;
        }
        printf("%d\n", answer);
    }
    return 0;
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值