bestcoder round#86解题报告

Price List

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 857    Accepted Submission(s): 454


Problem Description
There are  n  shops numbered with successive integers from  1  to  n  in Byteland. Every shop sells only one kind of goods, and the price of the  i -th shop's goods is  vi .

Every day, Byteasar will purchase some goods. He will buy at most one piece of goods from each shop. Of course, he can also choose to buy nothing. Back home, Byteasar will calculate the total amount of money he has costed that day and write it down on his account book.

However, due to Byteasar's poor math, he may calculate a wrong number. Byteasar would not mind if he wrote down a smaller number, because it seems that he hadn't used too much money.

Please write a program to help Byteasar judge whether each number is sure to be strictly larger than the actual value.
 

Input
The first line of the input contains an integer  T   (1T10) , denoting the number of test cases.

In each test case, the first line of the input contains two integers  n,m   (1n,m100000) , denoting the number of shops and the number of records on Byteasar's account book.

The second line of the input contains  n  integers  v1,v2,...,vn   (1vi100000) , denoting the price of the  i -th shop's goods.

Each of the next  m  lines contains an integer  q   (0q1018) , denoting each number on Byteasar's account book.
 

Output
For each test case, print a line with  m  characters. If the  i -th number is sure to be strictly larger than the actual value, then the  i -th character should be '1'. Otherwise, it should be '0'.
 

Sample Input
  
  
1 3 3 2 5 4 1 7 10000
 

Sample Output
  
  
001
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5901  5900  5899  5898  5897 
 
略水

#include<cstdio>
#include<algorithm>
#define LL long long
using namespace std;
const int N = 100000+10;
LL a[N],b[N];
int main() {
	int T;
	scanf("%d",&T);
	while(T--) {
		LL n,m;
		LL sum=0,q;
		scanf("%lld%lld",&n,&m);
		for(int i=0; i<n; i++) {
			scanf("%lld",&a[i]);
			sum+=a[i];
		}
		for(int i=0;i<m;i++){
			scanf("%lld",&b[i]);
		}
		for(int i=0;i<m;i++){
			if(b[i]>sum)
				printf("1");
			else
				printf("0");
		}
		printf("\n");
	}
	return 0;
}

NanoApe Loves Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 1142    Accepted Submission(s): 467


Problem Description
NanoApe, the Retired Dog, has returned back to prepare for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with  n  numbers on the paper and then randomly deleted a number in the sequence. After that, he calculated the maximum absolute value of the difference of each two adjacent remained numbers, denoted as  F .

Now he wants to know the expected value of  F , if he deleted each number with equal probability.
 

Input
The first line of the input contains an integer  T , denoting the number of test cases.

In each test case, the first line of the input contains an integer  n , denoting the length of the original sequence.

The second line of the input contains  n  integers  A1,A2,...,An , denoting the elements of the sequence.

1T10, 3n100000, 1Ai109
 

Output
For each test case, print a line with one integer, denoting the answer.

In order to prevent using float number, you should print the answer multiplied by  n .
 

Sample Input
  
  
1 4 1 2 3 4
 

Sample Output
  
  
6
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5901  5900  5899  5898  5897 
 

思维题

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#define LL long long
using namespace std;
const int N = 100000+10;
int a[N],l[N],r[N];
int main(){
	int T,n;
	scanf("%d",&T);
	while(T--){
		memset(l,0,sizeof(l));
		memset(r,0,sizeof(r));
		scanf("%d",&n);
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
		}
		for(int i=1;i<n;i++){
			l[i]=max(l[i-1],abs(a[i]-a[i-1]));
		}
		for(int i=n-2;i>=0;i--){
			r[i]=max(abs(a[i]-a[i+1]),r[i+1]);
		}
		LL ans=0;
		for(int i=0;i<n;i++){
			if(i==0)
				ans+=r[i+1];
			else if(i==n-1)
				ans+=l[i-1];
			else
				ans+=max(abs(a[i+1]-a[i-1]),max(r[i+1],l[i-1]));
		}
		printf("%lld\n",ans); 
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值