/*
<strong>描述</strong>
计算字符串最后一个单词的长度,单词以空格隔开。
知识点 字符串,循环
运行时间限制 0M
内存限制 0
<strong>输入</strong>
一行字符串,长度小于128。
<strong>输出</strong>
整数N,最后一个单词的长度。
样例输入 hello world
样例输出 5
*/
import java.io.BufferedInputStream;
import java.io.DataInputStream;
import java.io.IOException;
public class Main {
public static void main(String args[])
{
DataInputStream input = new DataInputStream(new BufferedInputStream(System.in));
String line;
int LineLength,i = 0;
try
{
line = input.readLine();
LineLength = line.length();
while((LineLength != 0) && (line.charAt(--LineLength) != ' ') )
{
i++;
}
}
catch(IOException ex)
{
ex.printStackTrace();
}
System.out.println(i);
}
}
暑假待学校没事干,就自己找的华为OJ题,先从最简单的开始做起,希望大家可以对我写的代码提出一些意见,共同进步!