牛人题目(位运算二)

Description
The binomial coefficient C(n, k) has been extensively studied for its importance in combinatorics. Binomial coefficients can be recursively defined as follows:


C(n, 0) = C(n, n) = 1 for all n > 0;
C(n, k) = C(n − 1, k − 1) + C(n − 1, k) for all 0 < k < n.

Given n and k, you are to determine the parity of C(n, k).
Input
The input contains multiple test cases. Each test case consists of a pair of integers n and k (0 ≤ k ≤ n < 2^31, n > 0) on a separate line.


End of file (EOF) indicates the end of input.
Output
For each test case, output one line containing either a “0” or a “1”, which is the remainder of C(n, k) divided by two.
Sample Input
1 1

1 0
2 1
Sample Output
1

1
0

#include<iostream>
using namespace std;
int main()
{
   long long  int n,k;
    while(cin>>n>>k)
    {
       
     if(k&(n-k))
        cout<<0<<endl;
     else cout<<1<<endl;
   
    }


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值