poj Binomial Coefficients (Lucas定理)

Binomial Coefficients
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 6819 Accepted: 2844

Description

The binomial coefficient C(n, k) has been extensively studied for its importance in combinatorics. Binomial coefficients can be recursively defined as follows:

C(n, 0) = C(n, n) = 1 for all n > 0;
C(n, k) = C(n − 1, k − 1) + C(n − 1, k) for all 0 < k < n.

Given n and k, you are to determine the parity of C(n, k).

Input

The input contains multiple test cases. Each test case consists of a pair of integers n and k (0 ≤ kn < 231, n > 0) on a separate line.

End of file (EOF) indicates the end of input.

Output

For each test case, output one line containing either a “0” or a “1”, which is the remainder of C(n, k) divided by two.

Sample Input

1 1
1 0
2 1

Sample Output

1
1
0

Source

//题意:

给出C(n,k)的计算规则:

C(n, 0) = C(n, n) = 1 for all n > 0;
C(n, k) = C(n − 1, k − 1) + C(n − 1, k) for all 0 < k < n.

要判断C(n,k)是否模2为1(即C(n,k)为奇数),由Lucas定理可知,C(n,k)mod 2=C(a[m],b[m])×C(a[m-1],b[m-1)×...×C(a[0],b[0])mod 2,其中,a[m]a[m-1]...a[0],b[m]b[m-1]...b[0]分别为n,k的二进制表示。所以我们只需保证 n二进制位上为0的点 对应的 k二进制位上的该位置的值 不为1即可(C(0,1)=0,C(0,0)=C(1,0)=C(1,1)=1)。注意到0&1=0,0&0=0,1&0=0,1&1=1,即,只有存在C(0,1)时,n和k做位与运算后得到的值才和k不相等,那么如果不存在C(0,1),即C(n,k)为奇数时,n&k是等于k的。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<algorithm>
#include<iostream>
#define INF 0x3f3f3f3f
#define ull unsigned long long
#define ll long long
#define IN __int64
#define N 110
#define M 1000000007
using namespace std;
int main()
{
	ll n,k;
	while(scanf("%lld%lld",&n,&k)!=EOF)
	{
		if((n&k)==k)
			printf("1\n");
		else
			printf("0\n");
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值