Part-time Job

Part-time <wbr>Job1013:Part-time Job

Time Limit:1000MS Memory Limit:65536K
Total Submit:257 Accepted:167 Page View:267

[Submit] [Status] [Discuss]

Font Size: Aa Aa Aa

Description

Snoopy lost his wallet, but he is afraid to tell his family, so he decided to do a part-time job to earn money in weekends. He is selling  

washing machines in a big market, he will get p dollars by sold a washing machine, and the manager promised him that snoopy will get
at least m dollars a day, it means that if snoopy didn't sold as many washing machines to get m dollars, the manager will pay him m dollars also.

Now we told you the p and m, and the number of washing machines snoopy sold in a day, which we call it n, help snoopy to calculate
how many dollars he can get.

Input

There are multiple test cases in the input file. Each line is a test case, there is three integers m, p, and n which are descript in the problem. 

Input is terminated by p = n = m = 0. ( 1 <= p, n, m <= 100 )

Output

For each test case, output an integer that the payment snoopy can get in a single line.

Sample Input

20 5 3 

20 5 5
0 0 0

Sample Output

20 

25
看了半天才看出题意的,太忽悠人了,不过这题水到家了!
#include<iostream>
using namespace std;
int main()
{
      int m,p,n;
   while(cin>>m>>p>>n)
   {
   if(m==0&&n==0&&p==0)
     break;
   else
   {
    if(m>=p*n)
      cout<<m<<endl;
    else
      cout<<p*n<<endl;
   
   }
   
   
   }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值