WOJ1290-Exchange

Knuthocean's teacher asked him to sort some numbers ascending and get the times of exchanges (exchanges happen only between two neighboring letters), can you help him?

输入格式

There are multiple test case, for each test case, the first line contain an integer n(n<10000), the second line contain n integers.
The last line of input contains a single number 0.

输出格式

Output the least times of the exchanges during the sort.

样例输入

5
1 2 3 4 5
4
1 3 2 4
0

样例输出

0
1


#include<stdio.h> 
int a[10000];
int main(){
 	int n,i,j,ans,t;
 	while(scanf("%d",&n)){
 		if(n==0) break; 
 		for(i=0;i<n;i++)
 			scanf("%d",&a[i]);
 		ans=0;
 		for(i=0;i<n-1;i++){
 			for(j=0;j<n-1-i;j++){
 				if(a[j]>a[j+1]){
 					t=a[j];
 					a[j]=a[j+1];
 					a[j+1]=t;
					ans++;
			    }
			}
		}
	    printf("%d\n",ans);
	}
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值