GPA

GPA

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1118 Accepted Submission(s): 466

Problem Description
Each course grade is one of the following five letters: A, B, C, D, and F. (Note that there is no grade E.) The grade A indicates superior achievement , whereas F stands for failure. In order to calculate the GPA, the letter grades A, B, C, D, and F are assigned the following grade points, respectively: 4, 3, 2, 1, and 0.

Input
The input file will contain data for one or more test cases, one test case per line. On each line there will be one or more upper case letters, separated by blank spaces.

Output
Each line of input will result in exactly one line of output. If all upper case letters on a particular line of input came from the set {A, B, C, D, F} then the output will consist of the GPA, displayed with a precision of two decimal places. Otherwise, the message "Unknown letter grade in input" will be printed.

Sample Input
A B C D F
B F F C C A
D C E F

Sample Output
2.00
1.83
Unknown letter grade in input

Author
2006Rocky Mountain Warmup

Source
HDU “Valentines Day” Open Programming Contest 2009-02-14

Recommend
lcy

#include<iostream>
#include<cstring>
#include<stdio.h>
using namespace
std;
int
main()
{

   int
i,k,len,b[1000];
   char
a[1000];
   while
(gets(a))
   {

  bool
flag=1;
     float
sum=0.0;
     k=0;
  len=strlen(a);
  memset(b,0,sizeof(b));
  for
(i=0;i<len;i++)
  {

   if
(a[i]=='A')
   b[i]=4;
   else if
(a[i]=='B')
   b[i]=3;
   else if
(a[i]=='C')
   b[i]=2;
   else if
(a[i]=='D')
   b[i]=1;
   else if
(a[i]=='F')
   b[i]=0;
   else if
(a[i]==' ')
    b[i]=0;
   else

    flag=0;
  }

  if
(flag)
  {

     for
(i=0;i<len;i++)
sum+=b[i];
float
avr=0.0;
avr=2*sum/(len+1);
cout.setf(ios::fixed);
cout.precision(2);
cout<<avr<<endl;
  }

  else

  cout<<"Unknown letter grade in input"<<endl;
   }


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值