Problem 81 » Red and Black

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

INPUT

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)

OUTPUT

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

SAMPLE INPUT

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

SAMPLE OUTPUT

45
59
6
13

 

#include<iostream>
using namespace std;
int num,w,h;
char a[21][21];
bool f(int x,int y)
{
   if(x<0||x>=h||y<0||y>=w)
   return 0;
   else
   return 1;
}
void dps(int x,int y)
{
   if(f(x,y)&&a[x][y]=='.')
   {
     a[x][y]='#';
    num++;
    dps(x-1,y);
    dps(x+1,y);
    dps(x,y-1);
    dps(x,y+1);
   }
  
}
int main()
{
    int i,j;
 while(cin>>w>>h&&w!=0&&h!=0)
 {
  for(i=0;i<h;i++)
   for(j=0;j<w;j++)
   cin>>a[i][j];
  num=0;
  for(i=0;i<h;i++)
   for(j=0;j<w;j++)
    if(a[i][j]=='@')
    {
      a[i][j]='.';
     dps(i,j);
    }
  cout<<num<<endl;
 }

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
抱歉,我无法以当前的文本格式直接转换成图片及按钮。但是,您可以使用HTML和JavaScript代码创建一个类似的效果。 以下是一个示例代码,其中包括一个图片和两个按钮,用于放大和缩小该图片: ```html <!DOCTYPE html> <html> <head> <title>Navbar example</title> <style> .container { display: flex; flex-direction: column; align-items: center; justify-content: center; height: 100vh; } img { max-width: 100%; max-height: 80vh; } button { margin: 1rem; padding: 0.5rem 1rem; font-size: 1rem; background-color: #007bff; color: #fff; border: none; border-radius: 0.25rem; cursor: pointer; } </style> </head> <body> <main class="container"> <div class="bg-light p-5 rounded text-center"> <h1>Navbar example</h1> <p class="text-center">This example is a quick exercise to illustrate how the top-aligned navbar works. As you scroll, this navbar remains in its original position and moves with the rest of the page.</p> <img id="image" src="https://via.placeholder.com/500x300" alt="image"> <div> <button id="zoom-in">Zoom In</button> <button id="zoom-out">Zoom Out</button> </div> </div> </main> <script> const image = document.getElementById('image'); const zoomInButton = document.getElementById('zoom-in'); const zoomOutButton = document.getElementById('zoom-out'); let scale = 1; zoomInButton.addEventListener('click', () => { scale += 0.1; image.style.transform = `scale(${scale})`; }); zoomOutButton.addEventListener('click', () => { scale -= 0.1; image.style.transform = `scale(${scale})`; }); </script> </body> </html> ``` 在这个示例中,我们创建了一个带有图片和两个按钮的容器,并使用CSS样式对其进行布局。在JavaScript代码中,我们为放大和缩小按钮添加了事件监听器,并使用CSS transform属性来控制图像的缩放比例。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值