Sum of Consecutive Primes

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2
题目大意:给你一个数,让你判断能由几个 一段连续的素数相加(即和)构成。
解题思路:
     先用素数筛选法标记素数,再进行预处理(暴力。
代码:
   #include<stdio.h>
int a[10010]= {0},b[10010]= {0};
int main()
{
    int n,i,sum,j,k;
    for(i=2; i<=10000; i++)
    {
        if(a[i]==0)
            for(j=2*i; j<=10000; j+=i)
                a[j]=1;
    }
    sum=0;
    for(i=2; i<=10000; i++)
    {
        if(a[i]==0)
            for(j=i; j<=10000; j++)
            {
                if(a[j]==0)
                {
                    sum+=j;
                    if(sum>10000)//防止爆内存
                        break;
                    b[sum]++;
                }
            }
        sum=0;
    }
    for(;;)
    {
        scanf("%d",&n);
        if(n==0)
            break;
        printf("%d\n",b[n]);
    }
    return 0;
}
 
  
 
  
 
  
 
  
 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值