- 博客(685)
- 资源 (25)
- 收藏
- 关注
原创 MySQL关闭sql_mode的only_full_group_by
MySQL 的 sql_mode 系统变量,简单来说,就是一套用来控制 MySQL 行为“严格程度”的规则。分区的风险:如果在创建了包含用户自定义分区的表之后,再更改 sql_mode,可能导致数据丢失或损坏。官方强烈建议,一旦创建了分区表,就不要再变更 sql_mode。查看当前完整的模式列表,复制出来,再删掉 ONLY_FULL_GROUP_BY 后填入配置文件,避免遗漏。修改配置:在 [mysqld] 部分,找到 sql_mode 这一行,将 ONLY_FULL_GROUP_BY 从列表中删除。
2026-07-31 17:02:18
244
原创 Yum安装MySQL8修改数据目录
修改mysql配置文件/etc/my.conf.d/mysql-server.conf。注意:如果关闭了selinux,这步可以忽略。复制数据文件到新数据目录,如:/data/mysql。使用mysql命令进入mysql修改root密码。# socket/pid 若也在新目录,同步设置。修改selinux/config。注意:[mysql]这个非常必要。注意:如果使用cp可能会有问题。安装的版本为8.0.34。下面要修改数据存储路径。
2026-07-31 16:43:26
312
原创 麒麟V10系统php7.2安装redis扩展
手头只有一个redis4.3就尝试一下,中途没有报错,生成了redis.so,修改php.ini挂在redis.so。有一台服务器系统为麒麟V10安装了php7.2.33,需要安装redis扩展。想去官网下载安装包,网站不稳定,无法访问pecl.php.net下载。正好手头有一个能连接互联网 的麒麟服务器,没有安装php任何版本。这台服务器无法连接互联网,所以没有办法使用pecl命令来安装。安装包下载到:/tmp/pear/download/复制到需要安装的服务器,再执行一次安装命令,成功。
2026-07-29 15:57:04
269
原创 windows11初始化跳过使用微软账户
安装了一个windows11,本来按照攻略按shift+F10,输入命令:oobe\bypassnro,重启,选择我没有Internet连接选项可以创建本地账号。可惜不小心连接了无线wifi,之后陷入死循环,重启无数次还是没出案件创建本地账号。如已经执行过oobe\bypassnro,会出现创建本地账号。如果还没执行过,可以按前面方法执行一次,再重启。重启,按ctr+shift+F3。
2026-07-29 15:36:31
212
原创 C盘太小,为它扩容
我在windows11上使用磁盘管理工具测试,如果有剩余空间,且剩余空间显示位置跟C盘紧挨着,那么是可以的。有个间接办法,用剩余空间创建一个分区,把紧挨着C盘的分区(如D盘)内容转移到新分区,然后删掉D盘,这样紧挨着C盘的位置就是空闲的。C盘太小,如果这块磁盘有其他分区,且有空余空间,可以将一部分划到C盘达到增容目的。右键选择有空闲的分区,按菜单提示操作即可。之后会要求重启,等待它自己完成。windows自带工具也有扩展分区空间的功能,但是有一定局限性。方法不知一种,这里介绍一个工具:傲梅分区助手。
2026-05-22 09:58:12
56
原创 华为云安装调试nfs服务问题和解决
第三段no_root_squash代表容许root身份登录(不推荐),如果填写root_squash代表登录的是root,压缩为nfsnobody。如果填写sync代表数据同步写入内存缓冲区和磁盘,效率低,但可以保证数据一致性。如果不是代表失败,那么请检查配置文件,通常是配置文件错误。10.0.1.4是允许访问的ip地址,也可以指定网段,如:192.168.1.0/24。10.0.1.1是nfs服务器地址,nfsdata是服务本地挂在目标文件夹。111是请求端口,2049是数据端口。
2026-05-22 09:40:54
187
原创 passwd修改密码提示“passwd:Moudle is unknown”
今天修改服务器密码,输入passwd命令后,命令行没有提示输入新密码,而是提示“passwd:Moudle: is unknown”后退出了passwd。忽然想起一件事,看到pam这个名字,大约在一个月前修改过system-auth文件,里面涉及到相关配置行。其他服务器在60天内都有update情况,因此与update相关的可能性不大。这文件如果丢失了,那么问题大了,是我自己无意中删除还是有非法进入的人删除?保存退出,再执行passwd,错误提示消失了。看来这个配置是有问题的,告知模块调用时出错。
2026-04-16 18:02:43
69
原创 Debian13关闭挂起和休眠
运行几天发现,这台机器会自动休眠。作为服务器用的主机,休眠功能有害无益,所以必须关闭它。该服务器安装了图形界面,在设置中设置了电源管理方案选择高性能。使用nano编辑/etc/systemd/sleep.conf。新安装了一台Debian13系统。基本一路按默认确认安装。这个图形界面不太好用,设置完居然画面无法操作了。nano保存使用ctl+o,退出使用ctl+x。经过测试,图形界面设置电源方案没有效果。图形界面不行,那么还是直接改配置文件吧。测试一天,系统没有再休眠或挂起。如图四项均设置为no。
2026-04-16 17:48:51
618
原创 Linux乱码解决
打包字体上传,确认是root属主和root组。最后java应用应进行一次重启,以加载新字体。放在/usr/share/fonts下。发布一个java编写的应用,结果乱码。以上命令如果不存在可使用yum安装。使用命令fc-cache更新缓存。使用命令fc-list查看字体。显然是系统缺乏中文字体支持。
2026-03-26 15:22:58
73
原创 spug发布失败
这个路径错误有点特殊性,路径中包含了多层,分隔符用了“\”,改用"/"即解决。首先是文件过滤,是包含还是排除根据实际情况选择。路径关键字正确也是必须的。这个重点检查应用变量的设置是否正确,本例检查出环境变量名有误。最后,如果不需要构建可直接发布的情况,应如下图不写代码即可。这个问题涉及路径的配置都要逐一检查。按提示,这是路径错误,打包的时候找不到文件和路径。第二个问题是代码检出后执行这块的代码里路径不正确。如上图,进入应用配置,给对应的应用配置变量。按提示,问题出在打包命令执行参数错误。
2026-03-26 15:16:17
195
原创 Linux云硬盘扩容实践
输入mkpart primary 2048s 100% (这里2048s为删除分区前牢记的数据,起始位置)解决办法是:编辑/etc/fstab文件,注释掉挂在vdb1硬盘那行,然后重启服务器。也可以编辑/etc/fstab文件把注释符号去掉,保存退出编辑运行命令mount -a。登陆服务器后,输入命令:parted /dev/vdb print。重启之后,确认/dev/vdb1没有挂载,之后进入下一步。输入print (查看信息,确认原分区已经删除)输入print (查看信息,牢记分区数据)
2026-03-16 17:08:30
97
原创 Linux普通用户设置开机自启服务
常见的有mysql、nginx等,通常可以使用sytemctl、chkconfig等服务来管理。这里介绍使用另一个服务来设置自启动服务或者脚本,适用于普通用户。有些服务是使用普通用户启动,并且可以设置为开机自启动。假定用户名为A,要启动一个在加目录下的脚本b.sh。这里使用任务计划服务crond来实现开机自启服务。注意“@reboot ”是设置重启时运行的命令。运行命令crontab -e。
2026-03-16 16:41:43
217
原创 腾讯云迁移设备总结
默认迁移执行时间8小时,如果数据太大可能导致执行超时,因此需要事先跟腾讯云说明数据较大这个情况,请他们调整执行时间。也就是需要先生升级到MySQL5.6,再升级到MySQL5.7。联系腾讯云的时候,需要确认目标区的资源。比如我选择的8区,缺乏1区的云硬盘类型。如果真的遇到这种情况,可以联系腾讯云技术协助修改这两个参数。在云控制台,点击云数据库实例,进入实例详情点击升级版本。有两个选择,本次选择了MySQL云盘版,点击立即升级。云服务器迁移需要请腾讯云的人协助,自己无法操作。完成这个过程后,就可以迁移了。
2026-01-20 17:17:31
412
原创 iphone8刷机
注意,此时需要的是绑定设备的appleid,如果中途更换过appleid,只要没有解绑,就必须用最开始那个appleid.此时如果因故iphone关机,没能立即激活,之后开机在手机上输入appleid激活也是可以的。打开爱思助手,点击下载固件,根据iphone型号下载固件。老婆的iphone8密码忘记了,连续是密码最后锁机了。进入DFU模式后,选择刚才下载的固件,开始刷机。考虑很久,里面没啥重要的东西,决定刷机。选择iphone,选择iphone8。点击智能刷机->专业刷机。下载完毕,准备开始刷机。
2026-01-05 21:14:41
285
原创 共享打印机成功后,提示“当前账户已锁定”
思考了一会,共享打印机使用管理员账户,在安全方面是存在风险的,推测windows内置了相关安全策略,发现来自多个主机使用了管理员账户会进行锁定。重新创建了一个非管理员账户,加入poweruser组,使用此账户连接共享打印机,测试账户不再锁定。在共享打印机的主机上,打开本地安全策略,找到账户策略下的账户锁定策略。删掉打印机,在运行中输入“ \\ip\”,稍后提示当前账户已锁定。另一台主机找到共享打印机后,连接成功,打印测试页也没问题。在共享打印机的主机上,管理里查看本地账户,发现确实锁定了。
2025-12-16 16:34:07
993
原创 Linux系统的硬链接
所以,目录虽然不可以通过ln创建硬链接,但是目录下创建子目录,每一个子目录下都有自动创建".."与父目录的硬链接。".."与上级的inode相同,所以父目录下创建一个子目录,其链接数+1(因为每个目录下都有..)硬链接是计算机文件系统中允许多个文件名指向同一文件的技术,以下要将的是linux系统下的硬链接。所以一个目录的硬连接数,等于1(自身)+1(目录下的 ".")+子目录数(其下的 "..")硬链接文件之间 具有相同的inode,用ls -lhi查看,第一列。i_link文件的硬链接数量。
2025-11-30 12:36:53
218
原创 360水滴摄像头重新设置摄像头wifi
少待,选择二维码方式,出现二维码后,将二维码放在摄像头前,稍微调整到合适距离,等到听到提示因,屏幕可离开摄像头。稍后1-2分钟,设置完成。长按,等听到“吡”的一声,此时摄像头重置成功,点击app中下一步按钮。打开360摄像机app,找到要重新连接wifi的摄像头,点击设置。家里路由器坏了,赶紧换了个新的。360摄像头因此离线了。然后按提示选择wifi,输入wifi密码。点击“让摄像机连接到其他wifi”。下一步就是重新设置摄像头网络。在设置页向下滑动,找到。
2025-11-12 21:12:26
1937
原创 手动安装联想打印机2268w驱动
联想打印机2268w接入网络,如果和主机不在同一网段或通过打印路由器接入网络,在执行安装程序后,可能无法自动找到打印机。打开windows设置页,找到打印机和扫描仪页。设备类型选择“TCP/IP”设备,填写打印机IP地址,点击下一步。点选“LNTHR6Z64.inf”,点击打开按钮,至此安装完成。选择“使用TCP/IP地址或主机名添加打印机”,点击下一步。点选“我需要的打印机不在列表中”,出现添加打印机页面。搜索结束,设备类型选择“自定义”,点击下一步。进入检测驱动型号,选择从磁盘安装。
2025-10-23 17:05:56
1038
原创 腾讯云负载均衡增加访问策略后访问失败
现在js文件加载失败,也就是CDN抓取服务器上js文件失败,准确说就是安全策略限制了CDN抓取。为了测试,在负载均衡的安全组添加2条安全策略,限制办公室内IP可访问,其他IP地址拒绝所有访问。控制台进入内容分发网络CDN,点击回援节点查询,在加速域名框内输入域名(CDN加速的域名)网络拓扑结构,在负载均衡前端配置了CDN,js缓存在cdn,定期从后端服务器抓取新版。查询结果出来,添加到安全组策略中,并允许访问相关端口。ip比较多,建议进入参数木板,创建ip地址集合。再进行测试,发现去掉安全策略后就正常了。
2025-09-09 17:35:01
550
原创 查看服务器进程使用内存
运行top命令,再按大写字母M.显示的内容将按照内存消耗值降序排列。top命令可以动态显示进程使用资源情况包括内存、CPU等。结合more命令、tail命令、head命令显示部分内容。使用pmap命令,可以查看进一步的内存映射情况。运行ps命令使用sort参数按内存升序排列P。服务器内存耗尽,真凶到底是那个进程?htop命令则是top命令的升级版。方法1:top和htop。pmap -x 进程号。
2025-09-09 15:48:51
380
原创 智能电视MaxHub恢复系统
只不过进入windows10后,图标不正常,而且也没有继续进入智能电视的系统中,左右两侧也没有快速进入的隐藏菜单。此时智能电视重启,依然按F2键,进入BIOS界面,按组合键Alt+F4,提示是否重启恢复系统,选择YES。为了在恢复过程中,提醒其他同事不要动智能电视,贴了一张纸提示,结果闹了乌龙。恢复系统后,屏幕一直抖动,如果接了鼠标,那个光标会明显在屏幕上抖动。恢复系统后,热点名称可能会有变化,但热点的密码保留了下来。反复折腾几次,自行修复执行完毕,终于可以进入系统了。按回车键,电视重启。
2025-08-25 17:27:10
1674
原创 GitLab升级后客户端推送和拉取代码认证失败
GitLab从7.10.x升级到17.11.1.过程无问题,重新启动服务后,研发反应拉取代码和推送代码都提示认证失败。
2025-05-08 15:17:03
420
原创 腾讯云服务器重启故障解决
公司一台云服务器更新内核后重启,之后发现无法连接。登陆控制台,使用vnc方式登陆发现服务器虽然启动了,但是提示需要输入root密码进入紧急模式。
2025-04-01 15:33:32
428
原创 家庭nas存储使用
这款nas提供的工具还有dlna,webdav,微信备份,文件整理(去除重复文件和相似照片整理)开启手机备份,提供了相册备份,视频备份,音频备份,文档备份,通讯录备份。工具中保险箱提供了加密存储,有安全需要的可以考虑。使用app,不在家也可以通过app访问家里的nas,当然会慢点。还有管理备份流量的选项,可以选是否在无wifi下进行备份。处于安全考虑,不建议开启匿名访问。2.家庭nas,不在家也可以访问。在第三方工具中,可以绑定百度网盘。在手机app中,有samba。点开,设置共享密码。
2025-03-09 21:28:51
573
原创 关机重启后,GitLab服务异常
整理机房,关闭了所有主机重新上架。上架后开机,所有主机硬件启动正常。其中一台GitLab服务器启动正常,使用gitlab-ctlstatus查看服务业正常。但使用web登陆却失败
2025-01-06 14:08:36
805
原创 升级ubuntu24后遗症
服务器最初安装了ubuntu18,大约1年多后升级到ubuntu20.前一个月升级到ubuntu22,无任何问题。有点大意了,觉得干脆升级到最新版ubuntu24.升级后发现openkm不能工作了,原因是mysql无法启动。
2025-01-02 13:41:51
649
原创 Dell服务器升级ubuntu 22.04失败解决
ubuntu系统原版本20.04,服务器dell T40.执行apt update后,再执行apt upgrade。保存文件,再次执行apt upgrade。将所有pam相关的配置行使用#注释掉。进入/etc/pam.d目录。
2024-12-31 11:05:06
1142
2
原创 Deepin登录后提示“解锁登陆密钥环里的密码不匹配”
Deppin忘记密码解决方案一文中,给出了重置密码的方法。但是该方法重置密码后登陆Deepin,登陆系统没问题,但是会提示“解锁登陆密钥环里的密码不匹配”。
2024-11-22 17:04:03
1290
原创 克隆容量不同的硬盘
新硬盘先进行分区,分区容量要跟老硬盘一致。以100G硬盘分区为例,分区时填写容量可以按照100*1.024来填写,这样显示容量就是100G。主机里有一块,500G,用了8年了,打算换一块。这块硬盘上面安装了一些软件,更换硬盘数据直接复制即可,安装的软件需要重新安装,很是麻烦。因为容量不一致,直接按硬盘克隆就不行了,需要按分区克隆。硬盘信息如上图,分了3个分区,1个主分区,1个扩展分区,2个逻辑分区。然后点击下一步,然后选择目标分区,之后按提示一路点击开始克隆。分区完成后,用win PE U盘启动。
2024-10-15 12:10:39
3070
原创 deepin桌面版连接windows远程桌面
在Linux系统中,要登录到Windows系统,通常可以使用远程桌面协议(RDP)。你需要在Linux系统上安装RDP客户端。使用如下命令安装rdp协议:
2024-09-23 18:42:20
2213
空空如也
TA创建的收藏夹 TA关注的收藏夹
TA关注的人
RSS订阅