统计同成绩学生的人数(简单的数组来hash查找)

题目
读入N名学生的成绩,将获得某一给定分数的学生人数输出。

Input
测试输入包含若干测试用例,每个测试用例的格式为

第1行:我接下来要输入N个成绩
第2行:N名学生的成绩,相邻两数字用一个空格间隔。
第3行:给定分数,我要看这个分数 多少人获得了。

当读到N=0时输入结束。其中N不超过1000,成绩分数为(包含)0到100之间的一个整数。

Output
对每个测试用例,将获得给定分数的学生人数输出。

Sample Input
3
80 60 90
60
2
85 66
0
5
60 75 90 55 75
75
0

Sample Output
1
0
2

分析
设置一个长度为101的整型数组(因为成绩是在0-100之间,所以有效长度为101),

用数字来hash

 

代码

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <map>
#include <stack>
using namespace std;

int main() {

    int n;
    while(cin >> n && n != 0) {
        int a[101] = {0}; // 0-100
        while(n--) {
            int t;
            cin >> t;
            a[t] ++;
        }
        int target;
        cin >> target;
        cout << a[target] << endl;
    }

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值