Java程序练习-数字问题

数字问题
时间限制: 1000ms内存限制: 1024kB
描述
求出在0到n之间,不能被表示成3个整数平方和的数的个数。
输入
一个正整数n,n<10000。
输出
所求个数个数。
样例输入
10
样例输出
1
参考代码
/*
 * Digit problem 2011-10-1 3:01PM Eric Zhou
 * 4^n * (8 * k + 7)
 */
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Iterator;
import java.util.Set;
import java.util.TreeSet;
public class Main {
	public static Set<Integer>set = new TreeSet<Integer>();
	public static void main(String[] args) throws IOException {
		BufferedReader cin = new BufferedReader(new InputStreamReader(System.in));
		int n = Integer.parseInt(cin.readLine().trim());
		init(n);
		int cnt = 0;
		Iterator<Integer>it = set.iterator();
		while(it.hasNext()){
			if(it.next() <= n)
				cnt ++;
		}
		System.out.println(cnt);
	}
	private static void init(int n) {
		int t = 0;
		for(int i = 0;i < 7;++ i){
			for(int j = 0;j < 2500;++ j){
				t = ((int)Math.pow(4,i)) * (8 * j + 7);
				set.add(t);
				if(t > n)
					break;
			}
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值